summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support
diff options
context:
space:
mode:
authorJuro Bystricky <juro.bystricky@intel.com>2017-10-30 10:49:46 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-11-08 22:23:44 +0000
commit6bc323ac9315712e75a0282cddb292bc84afc6f1 (patch)
treec4db7241e2c320b1c764414ecd43bc1d1b2f354d /meta/recipes-support
parent713761d23df24ad1b52e08bd2d2dc688393bef5b (diff)
downloadopenembedded-core-6bc323ac9315712e75a0282cddb292bc84afc6f1.tar.gz
curl_7.54.1.bb: improve reproducibility
Improve reproducible build of curl-dev and curl-dbg packages. curl-dev: Correctly remove build host references from curl-config curl-dbg: Do not generate time stamps in files generated by mkhelp.pl Signed-off-by: Juro Bystricky <juro.bystricky@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-support')
-rw-r--r--meta/recipes-support/curl/curl/reproducible-mkhelp.patch32
-rw-r--r--meta/recipes-support/curl/curl_7.54.1.bb10
2 files changed, 41 insertions, 1 deletions
diff --git a/meta/recipes-support/curl/curl/reproducible-mkhelp.patch b/meta/recipes-support/curl/curl/reproducible-mkhelp.patch
new file mode 100644
index 0000000000..268bbebf09
--- /dev/null
+++ b/meta/recipes-support/curl/curl/reproducible-mkhelp.patch
@@ -0,0 +1,32 @@
+From 1fe92fd3dd64c7228f6ff41e3fc16c4f2392471a Mon Sep 17 00:00:00 2001
+From: Juro Bystricky <juro.bystricky@intel.com>
+Date: Fri, 27 Oct 2017 08:28:25 -0700
+Subject: mkhelp.pl: support reproducible build
+
+Do not generate line with the current date, such as:
+
+* Generation time: Tue Oct-24 18:01:41 2017
+
+This will improve reproducibility. The generated string is only
+part of a comment, so there should be no adverse consequences.
+
+Upstream-Status: Submitted [ https://github.com/curl/curl/pull/2026 ]
+
+Signed-off-by: Juro Bystricky <juro.bystricky@intel.com>
+
+diff --git a/src/mkhelp.pl b/src/mkhelp.pl
+index 270daa2..757f024 100755
+--- a/src/mkhelp.pl
++++ b/src/mkhelp.pl
+@@ -102,11 +102,9 @@ while(<READ>) {
+ }
+ close(READ);
+
+-$now = localtime;
+ print <<HEAD
+ /*
+ * NEVER EVER edit this manually, fix the mkhelp.pl script instead!
+- * Generation time: $now
+ */
+ #ifdef USE_MANUAL
+ #include "tool_hugehelp.h"
diff --git a/meta/recipes-support/curl/curl_7.54.1.bb b/meta/recipes-support/curl/curl_7.54.1.bb
index 9870657ca4..58f05316fe 100644
--- a/meta/recipes-support/curl/curl_7.54.1.bb
+++ b/meta/recipes-support/curl/curl_7.54.1.bb
@@ -13,6 +13,10 @@ SRC_URI = "http://curl.haxx.se/download/curl-${PV}.tar.bz2 \
file://CVE-2017-1000254.patch \
"
+SRC_URI_append_class-target = " \
+ file://reproducible-mkhelp.patch \
+"
+
# curl likes to set -g0 in CFLAGS, so we stop it
# from mucking around with debug options
#
@@ -66,7 +70,11 @@ do_install_append() {
do_install_append_class-target() {
# cleanup buildpaths from curl-config
- sed -i -e 's,${STAGING_DIR_HOST},,g' ${D}${bindir}/curl-config
+ sed -i \
+ -e 's,--sysroot=${STAGING_DIR_TARGET},,g' \
+ -e 's,--with-libtool-sysroot=${STAGING_DIR_TARGET},,g' \
+ -e 's|${DEBUG_PREFIX_MAP}||g' \
+ ${D}${bindir}/curl-config
}
PACKAGES =+ "lib${BPN}"