summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2017-06-15 15:21:42 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-06-16 10:58:25 +0100
commit653704e9cf325cb494eb23facca19e9f05132ffd (patch)
treee0dccc9d5bf3b679257c905748fa269268d281e6 /meta/recipes-support
parent07f6c0b464f0671bc39116317138e4ddf27bdae9 (diff)
downloadopenembedded-core-653704e9cf325cb494eb23facca19e9f05132ffd.tar.gz
meta: Drop remnants of uclibc support
uclibc support was removed a while ago and musl works much better. Start to remove the various overrides and patches related to uclibc which are no longer needed. uclibc support in a layer would still be possible. I have strong reasons to believe nobody is still using uclibc since patches are missing and I doubt the metadata even parses anymore. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support')
-rw-r--r--meta/recipes-support/attr/ea-acl.inc3
-rw-r--r--meta/recipes-support/gnutls/gnutls.inc1
-rw-r--r--meta/recipes-support/icu/icu.inc2
-rw-r--r--meta/recipes-support/liburcu/liburcu_0.9.3.bb1
-rw-r--r--meta/recipes-support/rng-tools/rng-tools/uclibc-libuargp-configure.patch63
-rw-r--r--meta/recipes-support/rng-tools/rng-tools_5.bb3
6 files changed, 0 insertions, 73 deletions
diff --git a/meta/recipes-support/attr/ea-acl.inc b/meta/recipes-support/attr/ea-acl.inc
index c587b3caca..e6f4c72e8c 100644
--- a/meta/recipes-support/attr/ea-acl.inc
+++ b/meta/recipes-support/attr/ea-acl.inc
@@ -47,6 +47,3 @@ PACKAGES =+ "lib${BPN}"
FILES_lib${BPN} = "${base_libdir}/lib*${SOLIBS}"
BBCLASSEXTEND = "native"
-# Only append ldflags for target recipe and if USE_NLS is enabled
-LDFLAGS_append_libc-uclibc_class-target = "${@['', ' -lintl '][(d.getVar('USE_NLS') == 'yes')]}"
-EXTRA_OECONF_append_libc-uclibc_class-target = "${@['', ' --disable-gettext '][(d.getVar('USE_NLS') == 'no')]}"
diff --git a/meta/recipes-support/gnutls/gnutls.inc b/meta/recipes-support/gnutls/gnutls.inc
index e75d3a672c..29b5dd6ae7 100644
--- a/meta/recipes-support/gnutls/gnutls.inc
+++ b/meta/recipes-support/gnutls/gnutls.inc
@@ -46,7 +46,6 @@ EXTRA_OECONF = " \
"
LDFLAGS_append_libc-musl = " -largp"
-LDFLAGS_append_libc-uclibc = " -luargp -pthread"
do_configure_prepend() {
for dir in . lib; do
diff --git a/meta/recipes-support/icu/icu.inc b/meta/recipes-support/icu/icu.inc
index f3dc1e0abf..52862745e4 100644
--- a/meta/recipes-support/icu/icu.inc
+++ b/meta/recipes-support/icu/icu.inc
@@ -13,8 +13,6 @@ S = "${WORKDIR}/icu/source"
SPDX_S = "${WORKDIR}/icu"
STAGING_ICU_DIR_NATIVE = "${STAGING_DATADIR_NATIVE}/${BPN}/${PV}"
-CPPFLAGS_append_libc-uclibc = " -DU_TIMEZONE=0"
-
BINCONFIG = "${bindir}/icu-config"
inherit autotools pkgconfig binconfig
diff --git a/meta/recipes-support/liburcu/liburcu_0.9.3.bb b/meta/recipes-support/liburcu/liburcu_0.9.3.bb
index 4486e0abeb..926ba024ca 100644
--- a/meta/recipes-support/liburcu/liburcu_0.9.3.bb
+++ b/meta/recipes-support/liburcu/liburcu_0.9.3.bb
@@ -15,5 +15,4 @@ SRC_URI[md5sum] = "920970e35a1a2066c8353eabfeab8730"
SRC_URI[sha256sum] = "1bce32e6a6c967fef6d37adaadf33df19878d69673f9ef9d3f2470e0c6ed4006"
S = "${WORKDIR}/userspace-rcu-${PV}"
-CFLAGS_append_libc-uclibc = " -D_GNU_SOURCE"
inherit autotools
diff --git a/meta/recipes-support/rng-tools/rng-tools/uclibc-libuargp-configure.patch b/meta/recipes-support/rng-tools/rng-tools/uclibc-libuargp-configure.patch
deleted file mode 100644
index e691315d16..0000000000
--- a/meta/recipes-support/rng-tools/rng-tools/uclibc-libuargp-configure.patch
+++ /dev/null
@@ -1,63 +0,0 @@
-In case of uclibc, use libuargp
-
-If we use uclibc for system libraries, select libuargp
-
-Upstream-Status: Pending
-
-Signed-off-by: Maxin B. John <maxin.john@intel.com>
----
-diff -Naur rng-tools-5-orig/configure.ac rng-tools-5/configure.ac
---- rng-tools-5-orig/configure.ac 2016-02-24 18:11:24.023690235 +0200
-+++ rng-tools-5/configure.ac 2016-02-24 18:14:49.763118138 +0200
-@@ -39,6 +39,13 @@
- [with_libargp=check]
- )
-
-+AC_ARG_ENABLE([uclibc],
-+ AS_HELP_STRING([--enable-uclibc], [Use uclibc for system libraries]),
-+ use_uclibc=yes, use_uclibc=no)
-+AM_CONDITIONAL(USE_UCLIBC, test "x$use_uclibc" = "xyes")
-+AS_IF([test "x$use_uclibc" = "xyes"], [AC_DEFINE(USE_UCLIBC)])
-+AH_TEMPLATE([USE_UCLIBC], [Defined if uclibc libraries are used.])
-+
- dnl Make sure anyone changing configure.ac/Makefile.am has a clue
- AM_MAINTAINER_MODE
-
-@@ -101,7 +108,7 @@
- [need_libargp=no],
- [need_libargp=yes
- if test "x$with_libargp" = "xno"; then
-- AC_MSG_FAILURE([libargp disabled and libc does not have argp])
-+ AC_MSG_WARN([libargp disabled and libc does not have argp])
- fi]
- )
- ],
-@@ -110,7 +117,7 @@
-
- dnl Check for libargp
- AS_IF(
-- [test "x$need_libargp" = "xyes"],
-+ [test "x$need_libargp" = "xyes" -a "x$use_uclibc" = "xno"],
- [
- AC_CHECK_LIB(
- [argp],
-@@ -120,6 +127,19 @@
- )
- ]
- )
-+
-+dnl Check for libuargp
-+AS_IF(
-+ [test "x$use_uclibc" = "xyes"],
-+ [
-+ AC_CHECK_LIB(
-+ [uargp],
-+ [argp_parse],
-+ [LIBS="$LIBS -luargp"],
-+ [AC_MSG_FAILURE([libuargp not found])]
-+ )
-+ ]
-+)
-
- dnl -----------------
- dnl Configure options
diff --git a/meta/recipes-support/rng-tools/rng-tools_5.bb b/meta/recipes-support/rng-tools/rng-tools_5.bb
index e2acaba91a..de6e5f9a76 100644
--- a/meta/recipes-support/rng-tools/rng-tools_5.bb
+++ b/meta/recipes-support/rng-tools/rng-tools_5.bb
@@ -6,7 +6,6 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/gkernel/${BP}.tar.gz \
file://0001-If-the-libc-is-lacking-argp-use-libargp.patch \
file://0002-Add-argument-to-control-the-libargp-dependency.patch \
file://underquote.patch \
- file://uclibc-libuargp-configure.patch \
file://rng-tools-5-fix-textrels-on-PIC-x86.patch \
file://init \
file://default"
@@ -25,9 +24,7 @@ inherit autotools update-rc.d
PACKAGECONFIG = "libgcrypt"
PACKAGECONFIG_libc-musl = "libargp"
-PACKAGECONFIG_libc-uclibc = "libuargp"
PACKAGECONFIG[libargp] = "--with-libargp,--without-libargp,argp-standalone,"
-PACKAGECONFIG[libuargp] = "--enable-uclibc,,,"
PACKAGECONFIG[libgcrypt] = "--with-libgcrypt,--without-libgcrypt,libgcrypt,"
do_install_append() {