summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support
diff options
context:
space:
mode:
authorRasmus Villemoes <rasmus.villemoes@prevas.dk>2020-06-17 10:52:14 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-06-17 16:31:48 +0100
commit278242619eec5f5f143d57e92b109012001f1f91 (patch)
treee51ca1c696cb37b5b6cf42fa66a04203d04078b9 /meta/recipes-support
parentcb0213721893e5336995b38faffc7b65338a1b5f (diff)
downloadopenembedded-core-278242619eec5f5f143d57e92b109012001f1f91.tar.gz
curl: add debug info
Currently, curl (and libcurl) is built without debug info, making the curl-dbg package rather useless. Since debug symbols are automatically stripped and put in that package by the build system, making sure that curl is built with -g shouldn't hurt anything, but will help those that try to debug a libcurl-using application and hence explicitly include curl-dbg in their rootfs. Unfortunately, setting --enable-debug then changes the default value of the optimize option from (assume yes) to (assume no), while also changing the default value of the curldebug option [which is a separate thing that actually changes generated code to add some memory tracking] from (assume no) to (assume yes). So explicitly pass the appropriate options that make those two have the same value as they used to have by default. Signed-off-by: Rasmus Villemoes <rasmus.villemoes@prevas.dk> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support')
-rw-r--r--meta/recipes-support/curl/curl_7.70.0.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-support/curl/curl_7.70.0.bb b/meta/recipes-support/curl/curl_7.70.0.bb
index baf72f8e75..bb25677ef7 100644
--- a/meta/recipes-support/curl/curl_7.70.0.bb
+++ b/meta/recipes-support/curl/curl_7.70.0.bb
@@ -57,6 +57,9 @@ EXTRA_OECONF = " \
--with-ca-bundle=${sysconfdir}/ssl/certs/ca-certificates.crt \
--without-libmetalink \
--without-libpsl \
+ --enable-debug \
+ --enable-optimize \
+ --disable-curldebug \
"
do_install_append_class-target() {