summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support
diff options
context:
space:
mode:
authorEd Bartosh <ed.bartosh@linux.intel.com>2017-09-06 15:08:24 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-09-11 17:30:12 +0100
commit0d6130b30a1219b2bc2c57578f291311f69c676e (patch)
tree0b01929cf1ecb334bd3bba2e462ea845b2209304 /meta/recipes-support
parentfa36678698108023242f2afbd4e54d6709f84420 (diff)
downloadopenembedded-core-0d6130b30a1219b2bc2c57578f291311f69c676e.tar.gz
bmap-tools: switch to Python 3
bmap-tools is the only recipe in oe-core that still uses Python 2. Switching it to Python 3 should help to get rid of building native Python 2 and its dependencies. [YOCTO #11891] Signed-off-by: Ed Bartosh <ed.bartosh@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-support')
-rw-r--r--meta/recipes-support/bmap-tools/bmap-tools_3.4.bb7
1 files changed, 2 insertions, 5 deletions
diff --git a/meta/recipes-support/bmap-tools/bmap-tools_3.4.bb b/meta/recipes-support/bmap-tools/bmap-tools_3.4.bb
index 3f75fad44b..7454f9db75 100644
--- a/meta/recipes-support/bmap-tools/bmap-tools_3.4.bb
+++ b/meta/recipes-support/bmap-tools/bmap-tools_3.4.bb
@@ -16,10 +16,7 @@ S = "${WORKDIR}/git"
RDEPENDS_${PN} = "python-core python-compression python-mmap"
-inherit setuptools
+inherit python3native
+inherit setuptools3
BBCLASSEXTEND = "native"
-
-do_install_append_class-native() {
- sed -i -e 's|^#!.*/usr/bin/python-native/python|#! /usr/bin/env nativepython|' ${D}${bindir}/bmaptool
-}