aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support
diff options
context:
space:
mode:
authorMaxin B. John <maxin.john@intel.com>2016-08-22 14:15:40 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-09-02 08:48:04 +0100
commitcc567d8fb9eca630cd21d40ece99babcc5b7d045 (patch)
tree0c641c6db3b7ea1fc22109145c0c52672a7a20b7 /meta/recipes-support
parent0b56a2f6174a44495f8a58dc0864c161ffd37b80 (diff)
downloadopenembedded-core-cc567d8fb9eca630cd21d40ece99babcc5b7d045.tar.gz
curl: security fix for CVE-2016-5420
Affected versions: libcurl 7.1 to and including 7.50.0 Signed-off-by: Maxin B. John <maxin.john@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support')
-rw-r--r--meta/recipes-support/curl/curl/CVE-2016-5420.patch31
-rw-r--r--meta/recipes-support/curl/curl_7.47.1.bb1
2 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-support/curl/curl/CVE-2016-5420.patch b/meta/recipes-support/curl/curl/CVE-2016-5420.patch
new file mode 100644
index 0000000000..6bfacd7c9d
--- /dev/null
+++ b/meta/recipes-support/curl/curl/CVE-2016-5420.patch
@@ -0,0 +1,31 @@
+From 11ec5ad4352bba384404c56e77c7fab9382fd22d Mon Sep 17 00:00:00 2001
+From: Daniel Stenberg <daniel@haxx.se>
+Date: Sun, 31 Jul 2016 00:51:48 +0200
+Subject: [PATCH] TLS: only reuse connections with the same client cert
+
+Bug: https://curl.haxx.se/docs/adv_20160803B.html
+
+Upstream-Status: Backport
+https://curl.haxx.se/CVE-2016-5420.patch
+
+CVE: CVE-2016-5420
+Signed-off-by: Maxin B. John <maxin.john@intel.com>
+---
+ lib/vtls/vtls.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/lib/vtls/vtls.c b/lib/vtls/vtls.c
+index 33e209d..3863777 100644
+--- a/lib/vtls/vtls.c
++++ b/lib/vtls/vtls.c
+@@ -99,6 +99,7 @@ Curl_ssl_config_matches(struct ssl_config_data* data,
+ (data->verifyhost == needle->verifyhost) &&
+ safe_strequal(data->CApath, needle->CApath) &&
+ safe_strequal(data->CAfile, needle->CAfile) &&
++ safe_strequal(data->clientcert, needle->clientcert) &&
+ safe_strequal(data->random_file, needle->random_file) &&
+ safe_strequal(data->egdsocket, needle->egdsocket) &&
+ safe_strequal(data->cipher_list, needle->cipher_list))
+--
+2.4.0
+
diff --git a/meta/recipes-support/curl/curl_7.47.1.bb b/meta/recipes-support/curl/curl_7.47.1.bb
index 945840b1a9..8d459c75d6 100644
--- a/meta/recipes-support/curl/curl_7.47.1.bb
+++ b/meta/recipes-support/curl/curl_7.47.1.bb
@@ -12,6 +12,7 @@ SRC_URI = "http://curl.haxx.se/download/curl-${PV}.tar.bz2"
#
SRC_URI += " file://configure_ac.patch \
file://CVE-2016-5419.patch \
+ file://CVE-2016-5420.patch \
"
SRC_URI[md5sum] = "9ea3123449439bbd960cd25cf98796fb"