aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2014-06-02 21:04:59 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-06-03 16:45:04 +0100
commit2543b14dd0ca13005be0df027543431fc8e882ae (patch)
tree003ed12714ff59d4be59dcbf311d8cf1a73672fe /meta/recipes-support
parent0ced649c055dd25c500d0fd34e4ea94504d98580 (diff)
downloadopenembedded-core-2543b14dd0ca13005be0df027543431fc8e882ae.tar.gz
recipes: Add missing pkgconfig class inherits
These recipes all use pkg-config in some way but were missing dependencies on the tool, this patch adds them. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support')
-rw-r--r--meta/recipes-support/atk/at-spi2-atk_2.12.0.bb2
-rw-r--r--meta/recipes-support/atk/at-spi2-core_2.12.0.bb2
-rw-r--r--meta/recipes-support/gnupg/gnupg_2.0.22.bb2
-rw-r--r--meta/recipes-support/gpgme/gpgme_1.4.3.bb2
4 files changed, 4 insertions, 4 deletions
diff --git a/meta/recipes-support/atk/at-spi2-atk_2.12.0.bb b/meta/recipes-support/atk/at-spi2-atk_2.12.0.bb
index dac5ab415b..db6dc9032c 100644
--- a/meta/recipes-support/atk/at-spi2-atk_2.12.0.bb
+++ b/meta/recipes-support/atk/at-spi2-atk_2.12.0.bb
@@ -10,7 +10,7 @@ SRC_URI[sha256sum] = "3b5467c9f169812bc36a4245355b7deedea0a62eb22153df96ced88dcd
DEPENDS = "dbus glib-2.0 atk at-spi2-core"
-inherit autotools
+inherit autotools pkgconfig
PACKAGES =+ "${PN}-gnome ${PN}-gtk2"
diff --git a/meta/recipes-support/atk/at-spi2-core_2.12.0.bb b/meta/recipes-support/atk/at-spi2-core_2.12.0.bb
index bdda15ad8a..31e133fe43 100644
--- a/meta/recipes-support/atk/at-spi2-core_2.12.0.bb
+++ b/meta/recipes-support/atk/at-spi2-core_2.12.0.bb
@@ -10,7 +10,7 @@ SRC_URI[sha256sum] = "db550edd98e53b4252521459c2dcaf0f3b060a9bad52489b9dbadbaeda
DEPENDS = "dbus glib-2.0 virtual/libx11 libxi libxtst intltool-native"
-inherit autotools gtk-doc
+inherit autotools gtk-doc pkgconfig
EXTRA_OECONF = "--disable-introspection --disable-xevie"
diff --git a/meta/recipes-support/gnupg/gnupg_2.0.22.bb b/meta/recipes-support/gnupg/gnupg_2.0.22.bb
index 2746578bb2..0b003624c2 100644
--- a/meta/recipes-support/gnupg/gnupg_2.0.22.bb
+++ b/meta/recipes-support/gnupg/gnupg_2.0.22.bb
@@ -8,7 +8,7 @@ DEPENDS = "${PTH} libassuan libksba zlib bzip2 readline libgcrypt"
PTH = "pth"
PTH_libc-uclibc = "npth"
-inherit autotools gettext texinfo
+inherit autotools gettext texinfo pkgconfig
SRC_URI = "ftp://ftp.gnupg.org/gcrypt/${BPN}/${BPN}-${PV}.tar.bz2 \
file://pkgconfig.patch"
diff --git a/meta/recipes-support/gpgme/gpgme_1.4.3.bb b/meta/recipes-support/gpgme/gpgme_1.4.3.bb
index 5105430cb1..5a337d8a7e 100644
--- a/meta/recipes-support/gpgme/gpgme_1.4.3.bb
+++ b/meta/recipes-support/gpgme/gpgme_1.4.3.bb
@@ -19,7 +19,7 @@ DEPENDS = "libgpg-error libassuan"
EXTRA_OECONF = "--with-gpg=${bindir}/gpg --without-gpgsm"
-inherit autotools texinfo binconfig
+inherit autotools texinfo binconfig pkgconfig
PACKAGES =+ "${PN}-pthread"
FILES_${PN}-pthread = "${libdir}/libgpgme-pthread.so.*"