aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2012-05-25 09:15:39 +0000
committerScott Garman <scott.a.garman@intel.com>2012-11-30 14:50:15 -0800
commit54d27bbc26d1e45e51ee8ef0f051a2bd8f627cc0 (patch)
tree383656b6805318a343e2d4f2d42324e38b573def /meta/recipes-support
parentdd1b77c473ee92608ad0a5bdbea0880d2f613c2c (diff)
downloadopenembedded-core-54d27bbc26d1e45e51ee8ef0f051a2bd8f627cc0.tar.gz
libxml2/libxslt: Don't depend on ansidecl.h header
We don't DEPEND on binutils for ansidecl.h so ensure we should never use the header. This makes builds determinstic and means something like: bitbake binutils bitbake libxml2 -c configure bitbake binutils -c clean bitbake libxml2 doen't fail to build. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support')
-rw-r--r--meta/recipes-support/libxslt/libxslt_1.1.26.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/meta/recipes-support/libxslt/libxslt_1.1.26.bb b/meta/recipes-support/libxslt/libxslt_1.1.26.bb
index 8986e20723..e4cc21472b 100644
--- a/meta/recipes-support/libxslt/libxslt_1.1.26.bb
+++ b/meta/recipes-support/libxslt/libxslt_1.1.26.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://Copyright;md5=0cd9a07afbeb24026c9b03aecfeba458"
SECTION = "libs"
DEPENDS = "libxml2"
-PR = "r7"
+PR = "r8"
SRC_URI = "ftp://xmlsoft.org/libxslt//libxslt-${PV}.tar.gz \
file://pkgconfig_fix.patch"
@@ -18,6 +18,11 @@ S = "${WORKDIR}/libxslt-${PV}"
inherit autotools pkgconfig binconfig lib_package
+# We don't DEPEND on binutils for ansidecl.h so ensure we don't use the header
+do_configure_prepend () {
+ sed -i -e 's/ansidecl.h//' ${S}/configure.in
+}
+
EXTRA_OECONF = "--without-python --without-debug --without-mem-debug --without-crypto"
# older versions of this recipe had ${PN}-utils
RPROVIDES_${PN}-bin += "${PN}-utils"