summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/sqlite
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2015-10-16 14:28:11 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-11-16 11:28:42 +0000
commita23ddbd2e197cfa1ebc829e0d83b8997dc24cec7 (patch)
tree5a1200a7aa370890879e36f11b999996b660f521 /meta/recipes-support/sqlite
parent37bd229626a259d2509a9cdd2d6a2d934121e9ca (diff)
downloadopenembedded-core-a23ddbd2e197cfa1ebc829e0d83b8997dc24cec7.tar.gz
sqlite: 3.8.10.2 -> 3.9.0
Upgrade sqlite from 3.8.10.2 to 3.9.0. * update python function to get right SRC_URI * drop 0001-using-the-dynamic-library.patch which use dynamic library that it is done that way in new version Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-support/sqlite')
-rw-r--r--meta/recipes-support/sqlite/files/0001-using-the-dynamic-library.patch30
-rw-r--r--meta/recipes-support/sqlite/sqlite3_3.9.0.bb (renamed from meta/recipes-support/sqlite/sqlite3_3.8.10.2.bb)10
2 files changed, 5 insertions, 35 deletions
diff --git a/meta/recipes-support/sqlite/files/0001-using-the-dynamic-library.patch b/meta/recipes-support/sqlite/files/0001-using-the-dynamic-library.patch
deleted file mode 100644
index e3bfd5f656..0000000000
--- a/meta/recipes-support/sqlite/files/0001-using-the-dynamic-library.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-[PATCH] using the dynamic library
-
-Upstream-Status: Inappropriate [configuration]
-
-building statically-linked sqlite3 failed since sqlite3.o is generated in
-different dir, even if link successes, the size of sqlite3 is become larger,
-so use the dynamic link, ref: http://patchwork.openembedded.org/patch/93293/
-
-Signed-off-by: Roy Li <rongqing.li@windriver.com>
----
- Makefile.am | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/Makefile.am b/Makefile.am
-index 88bc23d..fe50f20 100644
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -7,7 +7,8 @@ libsqlite3_la_LDFLAGS = -no-undefined -version-info 8:6:8
-
- bin_PROGRAMS = sqlite3
- sqlite3_SOURCES = shell.c sqlite3.h
--sqlite3_LDADD = sqlite3.$(OBJEXT) @READLINE_LIBS@
-+sqlite3_LDADD = @READLINE_LIBS@ libsqlite3.la
-+
-
- include_HEADERS = sqlite3.h sqlite3ext.h
-
---
-1.9.1
-
diff --git a/meta/recipes-support/sqlite/sqlite3_3.8.10.2.bb b/meta/recipes-support/sqlite/sqlite3_3.9.0.bb
index c72ad50f60..50531ba9dd 100644
--- a/meta/recipes-support/sqlite/sqlite3_3.8.10.2.bb
+++ b/meta/recipes-support/sqlite/sqlite3_3.9.0.bb
@@ -4,16 +4,16 @@ LIC_FILES_CHKSUM = "file://sqlite3.h;endline=11;md5=65f0a57ca6928710b418c094b357
def sqlite_download_version(d):
pvsplit = d.getVar('PV', True).split('.')
+ if len(pvsplit) < 4:
+ pvsplit.append('0')
return pvsplit[0] + ''.join([part.rjust(2,'0') for part in pvsplit[1:]])
PE = "3"
SQLITE_PV = "${@sqlite_download_version(d)}"
-SRC_URI = "http://www.sqlite.org/2015/sqlite-autoconf-${SQLITE_PV}.tar.gz \
- file://0001-using-the-dynamic-library.patch \
-"
+SRC_URI = "http://www.sqlite.org/2015/sqlite-autoconf-${SQLITE_PV}.tar.gz"
-SRC_URI[md5sum] = "a18bfc015cd49a1e7a961b7b77bc3b37"
-SRC_URI[sha256sum] = "8382e55a4e7d853c93038562ca3dd00307937fccf1c6b65ddd813e503a56d626"
+SRC_URI[md5sum] = "cd0f883b2ddfc29e8e1bbbbd8e85f555"
+SRC_URI[sha256sum] = "a324143f4cc35cd7e9605a0a8dec9f9e4861d0be8305f3642e7d05008b77e60d"
S = "${WORKDIR}/sqlite-autoconf-${SQLITE_PV}"