summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/rng-tools
diff options
context:
space:
mode:
authorMaxin B. John <maxin.john@intel.com>2016-02-25 12:30:26 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-02-28 11:32:40 +0000
commit0bbbc0b377e4fd9a788f5aa7688afa5516e263dd (patch)
treeb9dbf3d2ca9f22700e0f1b01a4700b86abec8c18 /meta/recipes-support/rng-tools
parentbe7f5036a7c86fe70d43526df529bc467a9cf7d9 (diff)
downloadopenembedded-core-0bbbc0b377e4fd9a788f5aa7688afa5516e263dd.tar.gz
uclibc support for rng-tools
Uclibc has its own argp implemented as libuargp. So, we add a new option --enable-uclibc to select it. Signed-off-by: Maxin B. John <maxin.john@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-support/rng-tools')
-rw-r--r--meta/recipes-support/rng-tools/rng-tools/uclibc-libuargp-configure.patch63
-rw-r--r--meta/recipes-support/rng-tools/rng-tools_5.bb4
2 files changed, 66 insertions, 1 deletions
diff --git a/meta/recipes-support/rng-tools/rng-tools/uclibc-libuargp-configure.patch b/meta/recipes-support/rng-tools/rng-tools/uclibc-libuargp-configure.patch
new file mode 100644
index 0000000000..e691315d16
--- /dev/null
+++ b/meta/recipes-support/rng-tools/rng-tools/uclibc-libuargp-configure.patch
@@ -0,0 +1,63 @@
+In case of uclibc, use libuargp
+
+If we use uclibc for system libraries, select libuargp
+
+Upstream-Status: Pending
+
+Signed-off-by: Maxin B. John <maxin.john@intel.com>
+---
+diff -Naur rng-tools-5-orig/configure.ac rng-tools-5/configure.ac
+--- rng-tools-5-orig/configure.ac 2016-02-24 18:11:24.023690235 +0200
++++ rng-tools-5/configure.ac 2016-02-24 18:14:49.763118138 +0200
+@@ -39,6 +39,13 @@
+ [with_libargp=check]
+ )
+
++AC_ARG_ENABLE([uclibc],
++ AS_HELP_STRING([--enable-uclibc], [Use uclibc for system libraries]),
++ use_uclibc=yes, use_uclibc=no)
++AM_CONDITIONAL(USE_UCLIBC, test "x$use_uclibc" = "xyes")
++AS_IF([test "x$use_uclibc" = "xyes"], [AC_DEFINE(USE_UCLIBC)])
++AH_TEMPLATE([USE_UCLIBC], [Defined if uclibc libraries are used.])
++
+ dnl Make sure anyone changing configure.ac/Makefile.am has a clue
+ AM_MAINTAINER_MODE
+
+@@ -101,7 +108,7 @@
+ [need_libargp=no],
+ [need_libargp=yes
+ if test "x$with_libargp" = "xno"; then
+- AC_MSG_FAILURE([libargp disabled and libc does not have argp])
++ AC_MSG_WARN([libargp disabled and libc does not have argp])
+ fi]
+ )
+ ],
+@@ -110,7 +117,7 @@
+
+ dnl Check for libargp
+ AS_IF(
+- [test "x$need_libargp" = "xyes"],
++ [test "x$need_libargp" = "xyes" -a "x$use_uclibc" = "xno"],
+ [
+ AC_CHECK_LIB(
+ [argp],
+@@ -120,6 +127,19 @@
+ )
+ ]
+ )
++
++dnl Check for libuargp
++AS_IF(
++ [test "x$use_uclibc" = "xyes"],
++ [
++ AC_CHECK_LIB(
++ [uargp],
++ [argp_parse],
++ [LIBS="$LIBS -luargp"],
++ [AC_MSG_FAILURE([libuargp not found])]
++ )
++ ]
++)
+
+ dnl -----------------
+ dnl Configure options
diff --git a/meta/recipes-support/rng-tools/rng-tools_5.bb b/meta/recipes-support/rng-tools/rng-tools_5.bb
index bc679904eb..53d2d6165e 100644
--- a/meta/recipes-support/rng-tools/rng-tools_5.bb
+++ b/meta/recipes-support/rng-tools/rng-tools_5.bb
@@ -6,6 +6,7 @@ SRC_URI = "http://heanet.dl.sourceforge.net/sourceforge/gkernel/${BP}.tar.gz \
file://0001-If-the-libc-is-lacking-argp-use-libargp.patch \
file://0002-Add-argument-to-control-the-libargp-dependency.patch \
file://underquote.patch \
+ file://uclibc-libuargp-configure.patch \
file://init \
file://default"
@@ -23,8 +24,9 @@ inherit autotools update-rc.d
PACKAGECONFIG = "libgcrypt"
PACKAGECONFIG_libc-musl = "libargp"
-PACKAGECONFIG_libc-uclibc = "libargp"
+PACKAGECONFIG_libc-uclibc = "libuargp"
PACKAGECONFIG[libargp] = "--with-libargp,--without-libargp,argp-standalone,"
+PACKAGECONFIG[libuargp] = "--enable-uclibc,,,"
PACKAGECONFIG[libgcrypt] = "--with-libgcrypt,--without-libgcrypt,libgcrypt,"
do_install_append() {