summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/nettle/nettle_3.4.bb
diff options
context:
space:
mode:
authorArmin Kuster <akuster@mvista.com>2017-11-21 12:01:33 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-12-02 11:24:35 +0000
commit0b5d971a4e8e6904d2f4641fd5f3647d23ff4fa0 (patch)
treebbe5c0671198b1ab999c444037d42cfab71808c8 /meta/recipes-support/nettle/nettle_3.4.bb
parent537325f204f2f7c66f13a12dc8fc08f8e16e4754 (diff)
downloadopenembedded-core-0b5d971a4e8e6904d2f4641fd5f3647d23ff4fa0.tar.gz
nettle: update to 3.4 and cleanup
merge .inc forward ported two patches to work with 3.4 for more info see: http://lists.gnu.org/archive/html/info-gnu/2017-11/msg00007.html Change SRC_URI to use GNU download instead of liu.se, which interacts badly with wget 1.19.2 and downloads uncompressed tarballs (RB). Signed-off-by: Armin Kuster <akuster@mvista.com> Signed-off-by: Ross Burton <ross.burton@intel.com> XX nettle: update SRC_URI
Diffstat (limited to 'meta/recipes-support/nettle/nettle_3.4.bb')
-rw-r--r--meta/recipes-support/nettle/nettle_3.4.bb51
1 files changed, 51 insertions, 0 deletions
diff --git a/meta/recipes-support/nettle/nettle_3.4.bb b/meta/recipes-support/nettle/nettle_3.4.bb
new file mode 100644
index 0000000000..e88dba3989
--- /dev/null
+++ b/meta/recipes-support/nettle/nettle_3.4.bb
@@ -0,0 +1,51 @@
+SUMMARY = "A low level cryptographic library"
+HOMEPAGE = "http://www.lysator.liu.se/~nisse/nettle/"
+SECTION = "libs"
+LICENSE = "LGPLv3+ | GPLv2+"
+
+LIC_FILES_CHKSUM = "file://COPYING.LESSERv3;md5=6a6a8e020838b23406c81b19c1d46df6 \
+ file://COPYINGv2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
+ file://serpent-decrypt.c;beginline=14;endline=36;md5=ca0d220bc413e1842ecc507690ce416e \
+ file://serpent-set-key.c;beginline=14;endline=36;md5=ca0d220bc413e1842ecc507690ce416e"
+
+DEPENDS += "gmp"
+
+SRC_URI = "${GNU_MIRROR}/${BPN}/${BP}.tar.gz \
+ file://Add-target-to-only-build-tests-not-run-them.patch \
+ file://run-ptest \
+ file://check-header-files-of-openssl-only-if-enable_.patch \
+ "
+
+SRC_URI_append_class-target = "\
+ file://dlopen-test.patch \
+ "
+
+SRC_URI[md5sum] = "dc0f13028264992f58e67b4e8915f53d"
+SRC_URI[sha256sum] = "ae7a42df026550b85daca8389b6a60ba6313b0567f374392e54918588a411e94"
+
+UPSTREAM_CHECK_REGEX = "nettle-(?P<pver>\d+(\.\d+)+)\.tar"
+
+inherit autotools ptest
+
+EXTRA_OECONF = "--disable-openssl"
+
+do_configure_prepend() {
+ if [ ! -e ${S}/acinclude.m4 -a -e ${S}/aclocal.m4 ]; then
+ cp ${S}/aclocal.m4 ${S}/acinclude.m4
+ fi
+}
+
+do_compile_ptest() {
+ oe_runmake buildtest
+}
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/testsuite/
+ install ${S}/testsuite/gold-bug.txt ${D}${PTEST_PATH}/testsuite/
+ install ${S}/testsuite/*-test ${D}${PTEST_PATH}/testsuite/
+ # tools can be found in PATH, not in ../tools/
+ sed -i -e 's|../tools/||' ${D}${PTEST_PATH}/testsuite/*-test
+ install ${B}/testsuite/*-test ${D}${PTEST_PATH}/testsuite/
+}
+
+BBCLASSEXTEND = "native nativesdk"