summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libsoup
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@arm.com>2023-09-06 19:14:19 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-09-07 14:30:53 +0100
commit945071cc31280d3bd164478b50e2970b6a42fd02 (patch)
tree710e19cb0315d4e050988adc866851698820822a /meta/recipes-support/libsoup
parent54b6ea078daeb58a3bb20bb4275d1140640a77d2 (diff)
downloadopenembedded-core-945071cc31280d3bd164478b50e2970b6a42fd02.tar.gz
libsoup: update PACKAGECONFIG
Add explicit PACKAGECONFIGs for brotli,ntlm, and sysprof. libsoup needs to be told where ntlm_auth will be on the target, so write a cross file to do so. Also explicitly disable more of the test suites as we don't build them yet. Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/libsoup')
-rw-r--r--meta/recipes-support/libsoup/libsoup_3.4.2.bb19
1 files changed, 16 insertions, 3 deletions
diff --git a/meta/recipes-support/libsoup/libsoup_3.4.2.bb b/meta/recipes-support/libsoup/libsoup_3.4.2.bb
index 37e54abe73..ad86c890a1 100644
--- a/meta/recipes-support/libsoup/libsoup_3.4.2.bb
+++ b/meta/recipes-support/libsoup/libsoup_3.4.2.bb
@@ -24,11 +24,24 @@ inherit meson gettext pkgconfig upstream-version-is-even gobject-introspection g
GIR_MESON_ENABLE_FLAG = 'enabled'
GIR_MESON_DISABLE_FLAG = 'disabled'
-# libsoup-gnome is entirely deprecated and just stubs in 2.42 onwards. Disable by default.
PACKAGECONFIG ??= ""
+PACKAGECONFIG[brotli] = "-Dbrotli=enabled,-Dbrotli=disabled,brotli"
PACKAGECONFIG[gssapi] = "-Dgssapi=enabled,-Dgssapi=disabled,krb5"
-
-EXTRA_OEMESON:append = " -Dvapi=disabled -Dtls_check=false"
+PACKAGECONFIG[ntlm] = "-Dntlm=enabled,-Dntlm=disabled"
+PACKAGECONFIG[sysprof] = "-Dsysprof=enabled,-Dsysprof=disabled,sysprof"
+
+# Tell libsoup where the target ntlm_auth is installed
+do_write_config:append:class-target() {
+ cat >${WORKDIR}/soup.cross <<EOF
+[binaries]
+ntlm_auth = '${bindir}/ntlm_auth'
+EOF
+}
+EXTRA_OEMESON += "--cross-file ${WORKDIR}/soup.cross"
+
+EXTRA_OEMESON += "-Dvapi=disabled -Dtls_check=false"
+# Disable the test suites
+EXTRA_OEMESON += "-Dtests=false -Dautobahn=disabled -Dpkcs11_tests=disabled"
GIDOCGEN_MESON_OPTION = 'docs'
GIDOCGEN_MESON_ENABLE_FLAG = 'enabled'