aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libnl/libnl-2.0/fix-makefile.patch
diff options
context:
space:
mode:
authorQing He <qing.he@intel.com>2010-12-06 15:50:39 +0800
committerRichard Purdie <rpurdie@linux.intel.com>2010-12-06 22:02:27 +0000
commitb407939530291f7ddbfc6e220b0dba0d9edb8eaa (patch)
tree31593e63155ec473fe128f51a033555b1afe2a88 /meta/recipes-support/libnl/libnl-2.0/fix-makefile.patch
parent6940c96874194af19a10c3fa436d08e793f4fa42 (diff)
downloadopenembedded-core-b407939530291f7ddbfc6e220b0dba0d9edb8eaa.tar.gz
libnl: fix typo in the Makefile fix
change .$(OBJEXT) to .lo in the rule to reflect libtool setup Signed-off-by: Qing He <qing.he@intel.com>
Diffstat (limited to 'meta/recipes-support/libnl/libnl-2.0/fix-makefile.patch')
-rw-r--r--meta/recipes-support/libnl/libnl-2.0/fix-makefile.patch10
1 files changed, 9 insertions, 1 deletions
diff --git a/meta/recipes-support/libnl/libnl-2.0/fix-makefile.patch b/meta/recipes-support/libnl/libnl-2.0/fix-makefile.patch
index d9f00be2b6..214b0dbf76 100644
--- a/meta/recipes-support/libnl/libnl-2.0/fix-makefile.patch
+++ b/meta/recipes-support/libnl/libnl-2.0/fix-makefile.patch
@@ -5,6 +5,14 @@ otherwise the build of lib/route/pktloc.c may fail in a parallel
environment.
Signed-off-by: Qing He <qing.he@intel.com>
+
+12/06/2010
+
+the dependency rule should really read pktloc.lo instead of
+pktloc.$(OBJEXT), since it's in a libtool setup.
+
+Signed-off-by: Qing He <qing.he@intel.com>
+
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 92a916e..e8b8ef3 100644
--- a/lib/Makefile.am
@@ -13,7 +21,7 @@ index 92a916e..e8b8ef3 100644
route/pktloc_syntax.c: route/pktloc_syntax.y
$(YACC) -d $(YFLAGS) -o $@ $^
-+route/pktloc.$(OBJEXT): route/pktloc_syntax.h route/pktloc_grammar.h
++route/pktloc.lo: route/pktloc_syntax.h route/pktloc_grammar.h
+route/pktloc_syntax.h: route/pktloc_syntax.c
+route/pktloc_grammar.h: route/pktloc_grammar.c
+