summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libgpg-error
diff options
context:
space:
mode:
authorNathan Rossi <nathan@nathanrossi.com>2017-02-21 23:17:28 +1000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-03-04 23:18:09 +0000
commit45a5253a6c8d3e394c1a74491b95fc63a1616646 (patch)
tree8bd6a5f9aa1e579612c44c758b71c1ddf3beb7b2 /meta/recipes-support/libgpg-error
parentf57ec88a7c7f50cd40ebeadb4da150ab39a6b6d9 (diff)
downloadopenembedded-core-45a5253a6c8d3e394c1a74491b95fc63a1616646.tar.gz
libgpg-error: Don't replace the syscfg header for mingw32
For mingw32 targets do not attempt to replace the syscfg/lock-obj-pub.*.h as for mingw32 there are no arch specific headers that are included in the libgpg-error source. Signed-off-by: Nathan Rossi <nathan@nathanrossi.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-support/libgpg-error')
-rw-r--r--meta/recipes-support/libgpg-error/libgpg-error_1.26.bb11
1 files changed, 8 insertions, 3 deletions
diff --git a/meta/recipes-support/libgpg-error/libgpg-error_1.26.bb b/meta/recipes-support/libgpg-error/libgpg-error_1.26.bb
index b9e3b0065c..090db1b49b 100644
--- a/meta/recipes-support/libgpg-error/libgpg-error_1.26.bb
+++ b/meta/recipes-support/libgpg-error/libgpg-error_1.26.bb
@@ -26,7 +26,10 @@ inherit autotools binconfig-disabled pkgconfig gettext
CPPFLAGS += "-P"
do_compile_prepend() {
TARGET_FILE=linux-gnu
- if [ ${TARGET_OS} != "linux" ]; then
+ if [ ${TARGET_OS} = "mingw32" ]; then
+ # There are no arch specific syscfg files for mingw32
+ TARGET_FILE=
+ elif [ ${TARGET_OS} != "linux" ]; then
TARGET_FILE=${TARGET_OS}
fi
@@ -42,8 +45,10 @@ do_compile_prepend() {
*) TUPLE=${TARGET_ARCH}-unknown-linux-gnu ;;
esac
- cp ${S}/src/syscfg/lock-obj-pub.$TUPLE.h \
- ${S}/src/syscfg/lock-obj-pub.$TARGET_FILE.h
+ if [ -n "$TARGET_FILE" ]; then
+ cp ${S}/src/syscfg/lock-obj-pub.$TUPLE.h \
+ ${S}/src/syscfg/lock-obj-pub.$TARGET_FILE.h
+ fi
}
do_install_append() {