summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libcap
diff options
context:
space:
mode:
authorMike Crowe <mac@mcrowe.com>2015-04-30 16:51:13 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-05-03 11:39:46 +0100
commita8d35fa4fd76ea4a70063492cd5eab0858f2edb6 (patch)
tree56fdbd7b44afca4b3204f7d636a9231618a82a99 /meta/recipes-support/libcap
parentb4dc5b271247a1894d66908c5f20973be2a60d43 (diff)
downloadopenembedded-core-a8d35fa4fd76ea4a70063492cd5eab0858f2edb6.tar.gz
libcap: Avoid passing "-e" to make
oe-core 51540b64f62234c145fc32cfa3fbbaaebbeece08 altered libcap.inc (at the time) to append to EXTRA_OEMAKE rather than assign to it. The default value for EXTRA_OEMAKE contains "-e". This means that the change caused "-e" to be passed to make for the first time. Unfortunately passing "-e" subtly changes the behaviour of libcap's Make.Rules under recursive make when prefix="" (which it is for us since we're using meta-micro.) Without "-e" the prefix comes from the command line in both the parent and submakes. This takes precedence over any attempt to reassign it with a simple "=" operation so the headers are correctly installed in (empty string)/include. With "-e" the prefix still comes from the command line in the parent make but from the environment in the submake. The attempt to assign it fails in the parent make as before, but not in the submake so the headers are installed incorrectly in /usr/include. In all four cases the "ifdef prefix" else clause is executed. So, let's assign EXTRA_OEMAKE in order to avoid using "-e" at all. Signed-off-by: Mike Crowe <mac@mcrowe.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/libcap')
-rw-r--r--meta/recipes-support/libcap/libcap_2.24.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-support/libcap/libcap_2.24.bb b/meta/recipes-support/libcap/libcap_2.24.bb
index 75cf5d415d..f50dc941fe 100644
--- a/meta/recipes-support/libcap/libcap_2.24.bb
+++ b/meta/recipes-support/libcap/libcap_2.24.bb
@@ -32,7 +32,7 @@ PACKAGECONFIG_class-native ??= ""
PACKAGECONFIG[attr] = "LIBATTR=yes,LIBATTR=no,attr"
PACKAGECONFIG[pam] = "PAM_CAP=yes,PAM_CAP=no,libpam"
-EXTRA_OEMAKE += " \
+EXTRA_OEMAKE = " \
INDENT= \
lib=${@os.path.basename('${libdir}')} \
RAISE_SETFCAP=no \