summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/gpgme
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2016-01-13 19:40:52 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-22 23:42:54 +0000
commit29e1edcba39a21057ba5862eef4e79c177e7ef62 (patch)
treef8bf00125dc8f97dfa5437e852265a5ff57aad3c /meta/recipes-support/gpgme
parentc360290f22abfe9e37ca2fc0766b5a08a3276f6b (diff)
downloadopenembedded-core-29e1edcba39a21057ba5862eef4e79c177e7ef62.tar.gz
gpgme: Define __error_t_defined on musl
Configure looks for error_t in errno.h and musl does not define error_t if its not defined then configure emits a definition to be used, now we also use standalone argp implementation from glibc on musl based systems which defines this in argp.h as well so now we have it defined twice and errors like | /a/builder/mnt/build-oe/tmp-musl/sysroots/raspberrypi2/usr/include/argp.h:40:13: error: cannot combine with previous 'int' declaration specifier | typedef int error_t; | ^ | ../config.h:257:17: note: expanded from macro 'error_t' | #define error_t int | ^ | 1 error generated. are seen. argp.h definition is conditional on __error_t_defined which is true here so lets define it on musl Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta/recipes-support/gpgme')
-rw-r--r--meta/recipes-support/gpgme/gpgme_1.6.0.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-support/gpgme/gpgme_1.6.0.bb b/meta/recipes-support/gpgme/gpgme_1.6.0.bb
index 987d19bc4e..86eda239bf 100644
--- a/meta/recipes-support/gpgme/gpgme_1.6.0.bb
+++ b/meta/recipes-support/gpgme/gpgme_1.6.0.bb
@@ -27,6 +27,7 @@ PACKAGES =+ "${PN}-pthread"
FILES_${PN}-pthread = "${libdir}/libgpgme-pthread.so.*"
FILES_${PN}-dev += "${datadir}/common-lisp/source/gpgme/*"
+CFLAGS_append_libc-musl = " -D__error_t_defined "
do_configure_prepend () {
# Else these could be used in preference to those in aclocal-copy
rm -f ${S}/m4/gpg-error.m4