summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/gnutls
diff options
context:
space:
mode:
authorJoe Slater <jslater@windriver.com>2017-01-25 13:52:59 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-01-31 14:40:18 +0000
commit67f0094af624866f02e7fb0173c335a7e8942921 (patch)
treeddddf542bc32879ca534f83b8c95d478102d96d1 /meta/recipes-support/gnutls
parent59a99cd8661af594ee0c33e086578d29d50a6268 (diff)
downloadopenembedded-core-67f0094af624866f02e7fb0173c335a7e8942921.tar.gz
gnutls: account for ARM_EABI
Do not reference unavailable system calls when building for ARM_EABI. Signed-off-by: Joe Slater <jslater@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-support/gnutls')
-rw-r--r--meta/recipes-support/gnutls/gnutls/arm_eabi.patch19
-rw-r--r--meta/recipes-support/gnutls/gnutls_3.5.7.bb1
2 files changed, 20 insertions, 0 deletions
diff --git a/meta/recipes-support/gnutls/gnutls/arm_eabi.patch b/meta/recipes-support/gnutls/gnutls/arm_eabi.patch
new file mode 100644
index 0000000000..34c8985c19
--- /dev/null
+++ b/meta/recipes-support/gnutls/gnutls/arm_eabi.patch
@@ -0,0 +1,19 @@
+Certain syscall's are not availabe for arm-eabi, so we eliminate
+reference to them.
+
+Upstream-Status: Pending
+
+Signed-off-by: Joe Slater <jslater@windriver.com>
+
+--- a/tests/seccomp.c
++++ b/tests/seccomp.c
+@@ -49,7 +49,9 @@ int disable_system_calls(void)
+ }
+
+ ADD_SYSCALL(nanosleep, 0);
++#if ! defined(__ARM_EABI__)
+ ADD_SYSCALL(time, 0);
++#endif
+ ADD_SYSCALL(getpid, 0);
+ ADD_SYSCALL(gettimeofday, 0);
+ #if defined(HAVE_CLOCK_GETTIME)
diff --git a/meta/recipes-support/gnutls/gnutls_3.5.7.bb b/meta/recipes-support/gnutls/gnutls_3.5.7.bb
index cf77a20634..9508a8edcf 100644
--- a/meta/recipes-support/gnutls/gnutls_3.5.7.bb
+++ b/meta/recipes-support/gnutls/gnutls_3.5.7.bb
@@ -4,6 +4,7 @@ SRC_URI += "file://correct_rpl_gettimeofday_signature.patch \
file://0001-configure.ac-fix-sed-command.patch \
file://use-pkg-config-to-locate-zlib.patch \
file://0001-Do-not-add-cli-args.h-to-cli-args.stamp-Makefile-tar.patch \
+ file://arm_eabi.patch \
"
SRC_URI[md5sum] = "08ad2c539bc1d91283f610539deef34e"
SRC_URI[sha256sum] = "60cbfc119e6268cfa38d712621daa473298a0c5b129c0842caec4c1ed4d7861a"