summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/gmp
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2011-11-29 11:30:38 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-12-01 20:38:41 +0000
commitac59ea9d55c2fae870fb60dbba920fefe1f3487f (patch)
tree7aa73bb5f3db3fc295a3145e049b675f4afe521b /meta/recipes-support/gmp
parentb3e0c3a531b813d235c62109a7583e4995a859e4 (diff)
downloadopenembedded-core-ac59ea9d55c2fae870fb60dbba920fefe1f3487f.tar.gz
gmp: also generate the libgmpcxx library & package it properly
configure runs few checks to make sure c++ compiler and runtime are working as expected with the --enable-cxx=detect option. And it enables building of libgmpxx library. Same as earlier the libgmp.so.10.x file is packaged in the libgmp10 package, and a new package named libgmpxx4 is added for libgmpxx.so.4.x file. Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/gmp')
-rw-r--r--meta/recipes-support/gmp/gmp.inc5
-rw-r--r--meta/recipes-support/gmp/gmp_5.0.2.bb2
2 files changed, 6 insertions, 1 deletions
diff --git a/meta/recipes-support/gmp/gmp.inc b/meta/recipes-support/gmp/gmp.inc
index 66349e6e21..5ba118dabb 100644
--- a/meta/recipes-support/gmp/gmp.inc
+++ b/meta/recipes-support/gmp/gmp.inc
@@ -14,3 +14,8 @@ ARM_INSTRUCTION_SET = "arm"
acpaths = ""
BBCLASSEXTEND = "native nativesdk"
+
+EXTRA_OECONF += " --enable-cxx=detect"
+
+PACKAGES =+ "libgmpxx"
+FILES_libgmpxx = "${libdir}/libgmpxx${SOLIBS}"
diff --git a/meta/recipes-support/gmp/gmp_5.0.2.bb b/meta/recipes-support/gmp/gmp_5.0.2.bb
index 16bdcbc2b7..873fc3ea0e 100644
--- a/meta/recipes-support/gmp/gmp_5.0.2.bb
+++ b/meta/recipes-support/gmp/gmp_5.0.2.bb
@@ -2,7 +2,7 @@ require gmp.inc
LICENSE="LGPLv3&GPLv3"
LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
file://version.c;endline=18;md5=d8c56b52b9092346b9f93b4da65ef790"
-PR = "r1"
+PR = "r2"
SRC_URI_append += "file://sh4-asmfix.patch \
file://use-includedir.patch "