summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/boost
diff options
context:
space:
mode:
authorDmitry Rozhkov <dmitry.rozhkov@linux.intel.com>2017-05-15 14:54:32 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-05-30 10:14:31 +0100
commite1da4cc99e57c596b2a354767cc1e261718dac52 (patch)
treeaaa1eb5b3ee437c52bc983ac4d94894d770e4cbc /meta/recipes-support/boost
parent598e5da5a2af2bd93ad890687dd32009e348fc85 (diff)
downloadopenembedded-core-e1da4cc99e57c596b2a354767cc1e261718dac52.tar.gz
boost: backport a regression fix for forgotten header
The v1.64 release has broken array serialization code with issues reported in https://svn.boost.org/trac/boost/ticket/12516 https://github.com/bmwcarit/meta-ros/issues/505 Backport the fix from boost::serialization's master. Signed-off-by: Dmitry Rozhkov <dmitry.rozhkov@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/boost')
-rw-r--r--meta/recipes-support/boost/boost/0001-correct-error-which-appeared-when-compiling-non-c-co.patch28
-rw-r--r--meta/recipes-support/boost/boost_1.64.0.bb1
2 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-support/boost/boost/0001-correct-error-which-appeared-when-compiling-non-c-co.patch b/meta/recipes-support/boost/boost/0001-correct-error-which-appeared-when-compiling-non-c-co.patch
new file mode 100644
index 0000000000..2598d2b175
--- /dev/null
+++ b/meta/recipes-support/boost/boost/0001-correct-error-which-appeared-when-compiling-non-c-co.patch
@@ -0,0 +1,28 @@
+From 02fa5cee1b8d0321787113e2dc10b162c657f333 Mon Sep 17 00:00:00 2001
+From: Robert Ramey <ramey@rrsd.com>
+Date: Wed, 1 Feb 2017 16:43:59 -0800
+Subject: [PATCH] correct error which appeared when compiling non c++ compliant
+ code for arrays
+
+Upstream-Status: Backported [expected to be released in v1.65]
+
+---
+ boost/serialization/array.hpp | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/boost/serialization/array.hpp b/boost/serialization/array.hpp
+index 61708b3..612d1a6 100644
+--- a/boost/serialization/array.hpp
++++ b/boost/serialization/array.hpp
+@@ -23,6 +23,8 @@ namespace std{
+ } // namespace std
+ #endif
+
++#include <boost/serialization/array_wrapper.hpp>
++
+ #ifndef BOOST_NO_CXX11_HDR_ARRAY
+
+ #include <array>
+--
+2.9.3
+
diff --git a/meta/recipes-support/boost/boost_1.64.0.bb b/meta/recipes-support/boost/boost_1.64.0.bb
index 119eb0af45..d1c20e1d06 100644
--- a/meta/recipes-support/boost/boost_1.64.0.bb
+++ b/meta/recipes-support/boost/boost_1.64.0.bb
@@ -9,4 +9,5 @@ SRC_URI += "\
file://0001-Apply-boost-1.62.0-no-forced-flags.patch.patch \
file://0003-Don-t-set-up-arch-instruction-set-flags-we-do-that-o.patch \
file://0002-Don-t-set-up-m32-m64-we-do-that-ourselves.patch \
+ file://0001-correct-error-which-appeared-when-compiling-non-c-co.patch \
"