summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/boost
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2016-12-22 16:13:56 +1300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-01-09 13:34:29 +0000
commit603ae6eb487489e65da69c68e532cb767ccc1fc2 (patch)
treea54359e344397ed634084e61187775bce5e80cf7 /meta/recipes-support/boost
parent1e03ad25d8b9536d5e7f9969809a4df01e55fe3a (diff)
downloadopenembedded-core-603ae6eb487489e65da69c68e532cb767ccc1fc2.tar.gz
meta: use require instead of include when file should exist
If the file is expected to exist, then we should always be using require so that if it doesn't we get an error rather than some other more obscure failure later on. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-support/boost')
-rw-r--r--meta/recipes-support/boost/bjam-native_1.62.0.bb2
-rw-r--r--meta/recipes-support/boost/boost_1.62.0.bb4
2 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-support/boost/bjam-native_1.62.0.bb b/meta/recipes-support/boost/bjam-native_1.62.0.bb
index 32646d707b..46013f343b 100644
--- a/meta/recipes-support/boost/bjam-native_1.62.0.bb
+++ b/meta/recipes-support/boost/bjam-native_1.62.0.bb
@@ -1,4 +1,4 @@
-include boost-${PV}.inc
+require boost-${PV}.inc
SUMMARY = "Portable Boost.Jam build tool for boost"
SECTION = "devel"
diff --git a/meta/recipes-support/boost/boost_1.62.0.bb b/meta/recipes-support/boost/boost_1.62.0.bb
index 120d12968b..cde03f2b8e 100644
--- a/meta/recipes-support/boost/boost_1.62.0.bb
+++ b/meta/recipes-support/boost/boost_1.62.0.bb
@@ -1,5 +1,5 @@
-include boost-${PV}.inc
-include boost.inc
+require boost-${PV}.inc
+require boost.inc
SRC_URI += "\
file://arm-intrinsics.patch \