summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato
diff options
context:
space:
mode:
authorZhai Edwin <edwin.zhai@intel.com>2011-12-21 15:16:58 +0800
committerSaul Wold <sgw@linux.intel.com>2012-01-02 20:26:21 -0800
commitfb0cd3470e562f121803b722b16fd10620b79ff5 (patch)
treea63440d8d5f284f0f05b3670154a26804b5bcb61 /meta/recipes-sato
parent43c2d366622ea52cba8a5b727d723c8ec30bd44b (diff)
downloadopenembedded-core-fb0cd3470e562f121803b722b16fd10620b79ff5.tar.gz
Add mini X core tasks
Signed-off-by: Zhai Edwin <edwin.zhai@intel.com>
Diffstat (limited to 'meta/recipes-sato')
-rw-r--r--meta/recipes-sato/tasks/task-core-x11-mini.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/meta/recipes-sato/tasks/task-core-x11-mini.bb b/meta/recipes-sato/tasks/task-core-x11-mini.bb
new file mode 100644
index 0000000000..98189fe315
--- /dev/null
+++ b/meta/recipes-sato/tasks/task-core-x11-mini.bb
@@ -0,0 +1,45 @@
+#
+# Copyright (C) 2011 Intel Corporation
+#
+
+DESCRIPTION = "Tasks for core X11 applications"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
+ file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+PR = "r0"
+
+PACKAGES = "\
+ task-core-x11-mini \
+ task-core-x11-mini-dbg \
+ task-core-x11-mini-dev \
+ "
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+XSERVER ?= "xserver-kdrive-fbdev"
+
+ALLOW_EMPTY = "1"
+
+ROOTLESS_X = "1"
+
+# xserver-common, x11-common
+VIRTUAL-RUNTIME_xserver_common ?= "x11-common"
+
+# elsa, xserver-nodm-init
+VIRTUAL-RUNTIME_graphical_init_manager ?= "xserver-nodm-init"
+
+
+RDEPENDS_task-core-x11-mini = "\
+ dbus \
+ pointercal \
+ matchbox-terminal \
+ matchbox-wm \
+ mini-x-session \
+ ${XSERVER} \
+ ${VIRTUAL-RUNTIME_xserver_common} \
+ ${VIRTUAL-RUNTIME_graphical_init_manager} \
+ liberation-fonts \
+ xauth \
+ xhost \
+ xset \
+ xrandr"