summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato
diff options
context:
space:
mode:
authorZhai Edwin <edwin.zhai@intel.com>2012-05-30 17:08:28 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-05-30 17:37:58 +0100
commite3113827810e98eb1b012f0b280fb917199704c1 (patch)
tree5133010a103d3ad22f2e84d850089741ee06d5a0 /meta/recipes-sato
parent2bed83c6237669b6fc6fa25b2a554efb73395ca6 (diff)
downloadopenembedded-core-e3113827810e98eb1b012f0b280fb917199704c1.tar.gz
webkit-gtk: Use glib as unicode backend to avoid browser crash
webkit-gtk depends on ICU for the unicode, but ICU is not safe when build and target system owns different endian. ICU's community is not responsive to make a patch for this, so glib is used as work around here. [YOCTO #1570] got fixed Signed-off-by: Zhai Edwin <edwin.zhai@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-sato')
-rw-r--r--meta/recipes-sato/webkit/webkit-gtk_svn.bb10
1 files changed, 9 insertions, 1 deletions
diff --git a/meta/recipes-sato/webkit/webkit-gtk_svn.bb b/meta/recipes-sato/webkit/webkit-gtk_svn.bb
index 7db573d056..9381486e20 100644
--- a/meta/recipes-sato/webkit/webkit-gtk_svn.bb
+++ b/meta/recipes-sato/webkit/webkit-gtk_svn.bb
@@ -10,12 +10,13 @@ LIC_FILES_CHKSUM = "file://Source/WebCore/rendering/RenderApplet.h;endline=22;md
DEPENDS = "zlib enchant gnome-keyring libsoup-2.4 curl icu libxml2 cairo libxslt libxt libidn gnutls gtk+ gstreamer gst-plugins-base flex-native gperf-native perl-native-runtime sqlite3"
DEPENDS += " ${@base_contains('DISTRO_FEATURES', 'opengl', 'virtual/libgl', '', d)}"
DEPENDS_darwin8 = "curl icu libxml2 cairo libxslt libidn gnutls gtk+ gstreamer flex-native gperf-native perl-native-runtime sqlite3"
+DEPENDS_append_qemuppc += "pango"
SRCREV_FORMAT = "source"
SRCREV = "101488"
PV = "1.7.2+svnr${SRCPV}"
-PR = "r4"
+PR = "r5"
SRC_URI = "\
svn://svn.webkit.org/repository/webkit/trunk/;module=Source;proto=http;name=source \
@@ -47,6 +48,13 @@ EXTRA_OECONF = "\
UNICODE_CFLAGS=-D_REENTRANT \
"
+#default unicode backend icu breaks in cross-compile when target and host owns different endian type
+EXTRA_OECONF_append_qemuppc += "--with-unicode-backend=glib"
+
+CPPFLAGS_append_qemuppc += "-I${STAGING_INCDIR}/pango-1.0 \
+ -I${STAGING_LIBDIR}/glib-2.0/include \
+ -I${STAGING_INCDIR}/glib-2.0"
+
EXTRA_AUTORECONF = " -I Source/autotools "