summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2012-03-30 12:21:30 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-04-04 16:56:36 +0100
commitc870606c9da2fa90df2cd7c4a198e3bf5340304b (patch)
tree401dc253c1dc4bc93e105b5c096a5e34a73258c5 /meta/recipes-sato
parent514319c4a15156cd63a4ac3c6ee903f64c98884e (diff)
downloadopenembedded-core-c870606c9da2fa90df2cd7c4a198e3bf5340304b.tar.gz
webkit: Fix build with gcc-4.7
Include unistd.h for all linux and not just for android. Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta/recipes-sato')
-rw-r--r--meta/recipes-sato/webkit/files/function-scope.patch21
-rw-r--r--meta/recipes-sato/webkit/webkit-gtk_svn.bb3
2 files changed, 23 insertions, 1 deletions
diff --git a/meta/recipes-sato/webkit/files/function-scope.patch b/meta/recipes-sato/webkit/files/function-scope.patch
new file mode 100644
index 0000000000..a20a80501f
--- /dev/null
+++ b/meta/recipes-sato/webkit/files/function-scope.patch
@@ -0,0 +1,21 @@
+we need to include unistd.h on all linux platforms therefore
+extend the conditional inclusion accordingly
+
+This gets proper declation of sleep() into the source file
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+Upstream-Status: Pending
+Index: webkit-gtk-1.7.2+svnr101488-r3/Tools/DumpRenderTree/TestNetscapePlugIn/PluginTest.cpp
+===================================================================
+--- webkit-gtk-1.7.2+svnr101488-r3.orig/Tools/DumpRenderTree/TestNetscapePlugIn/PluginTest.cpp 2012-03-30 12:11:04.912613223 -0700
++++ webkit-gtk-1.7.2+svnr101488-r3/Tools/DumpRenderTree/TestNetscapePlugIn/PluginTest.cpp 2012-03-30 12:14:21.840622752 -0700
+@@ -29,7 +29,7 @@
+ #include <assert.h>
+ #include <string.h>
+
+-#if defined(ANDROID)
++#if defined(__linux__)
+ #include <unistd.h>
+ #endif
+
diff --git a/meta/recipes-sato/webkit/webkit-gtk_svn.bb b/meta/recipes-sato/webkit/webkit-gtk_svn.bb
index 9181c2cd2b..7db573d056 100644
--- a/meta/recipes-sato/webkit/webkit-gtk_svn.bb
+++ b/meta/recipes-sato/webkit/webkit-gtk_svn.bb
@@ -15,7 +15,7 @@ SRCREV_FORMAT = "source"
SRCREV = "101488"
PV = "1.7.2+svnr${SRCPV}"
-PR = "r3"
+PR = "r4"
SRC_URI = "\
svn://svn.webkit.org/repository/webkit/trunk/;module=Source;proto=http;name=source \
@@ -28,6 +28,7 @@ SRC_URI = "\
file://GNUmakefile.am \
file://gtk-doc.make \
file://nodolt.patch \
+ file://function-scope.patch \
"
S = "${WORKDIR}/"