aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato
diff options
context:
space:
mode:
authorLaurentiu Palcu <laurentiu.palcu@intel.com>2012-12-18 14:06:52 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-12-19 17:50:03 +0000
commita19592b684d482a7c011495f1c761f38c316319a (patch)
tree801e2438d9d3c2a8864c43d1824c7c6f3efa8651 /meta/recipes-sato
parent35ecd1e61ff6b3b338f413d942eabb247b815a0f (diff)
downloadopenembedded-core-a19592b684d482a7c011495f1c761f38c316319a.tar.gz
matchbox-session-sato: use a proper schema file
Also, inheriting gconf.bbclass will allow for the schema registration to be done at do_rootfs time. [YOCTO #3603] Signed-off-by: Laurentiu Palcu <laurentiu.palcu@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-sato')
-rw-r--r--meta/recipes-sato/matchbox-sato/matchbox-session-sato/matchbox-session-sato.schemas53
-rw-r--r--meta/recipes-sato/matchbox-sato/matchbox-session-sato_0.1.bb21
2 files changed, 60 insertions, 14 deletions
diff --git a/meta/recipes-sato/matchbox-sato/matchbox-session-sato/matchbox-session-sato.schemas b/meta/recipes-sato/matchbox-sato/matchbox-session-sato/matchbox-session-sato.schemas
new file mode 100644
index 0000000000..f5b770b62f
--- /dev/null
+++ b/meta/recipes-sato/matchbox-sato/matchbox-session-sato/matchbox-session-sato.schemas
@@ -0,0 +1,53 @@
+<?xml version="1.0"?>
+<gconfschemafile>
+<schemalist>
+
+ <schema>
+ <key>/schemas/desktop/poky/interface/theme</key>
+ <applyto>/desktop/poky/interface/theme</applyto>
+ <type>string</type>
+ <owner>matchbox-session-sato</owner>
+ <default>Sato</default>
+ <locale name="C">
+ <short>Desktop theme</short>
+ <long>The theme name for Matchbox and Sato to use.</long>
+ </locale>
+ </schema>
+
+ <schema>
+ <key>/schemas/desktop/poky/interface/icon_theme</key>
+ <applyto>/desktop/poky/interface/icon_theme</applyto>
+ <type>string</type>
+ <owner>matchbox-session-sato</owner>
+ <default>Sato</default>
+ <locale name="C">
+ <short>Desktop icon theme</short>
+ <long>The icon theme name for Matchbox and Sato.</long>
+ </locale>
+ </schema>
+
+ <schema>
+ <key>/schemas/desktop/poky/interface/touchscreen</key>
+ <applyto>/desktop/poky/interface/touchscreen</applyto>
+ <type>bool</type>
+ <owner>matchbox-session-sato</owner>
+ <default>true</default>
+ <locale name="C">
+ <short>Activate touchscreen</short>
+ </locale>
+ </schema>
+
+ <schema>
+ <key>/schemas/desktop/poky/interface/font_name</key>
+ <applyto>/desktop/poky/interface/font_name</applyto>
+ <type>string</type>
+ <owner>matchbox-session-sato</owner>
+ <default>Sans 9</default>
+ <locale name="C">
+ <short>Font name</short>
+ </locale>
+ </schema>
+
+</schemalist>
+</gconfschemafile>
+
diff --git a/meta/recipes-sato/matchbox-sato/matchbox-session-sato_0.1.bb b/meta/recipes-sato/matchbox-sato/matchbox-session-sato_0.1.bb
index 10fd5b42c5..2d34754281 100644
--- a/meta/recipes-sato/matchbox-sato/matchbox-session-sato_0.1.bb
+++ b/meta/recipes-sato/matchbox-sato/matchbox-session-sato_0.1.bb
@@ -16,7 +16,9 @@ PR = "r29"
# based on the machine architecture.
PACKAGE_ARCH = "${MACHINE_ARCH}"
-SRC_URI = "file://session"
+SRC_URI = "file://session \
+ file://matchbox-session-sato.schemas \
+ "
S = "${WORKDIR}"
do_install() {
@@ -34,18 +36,9 @@ do_install() {
install -d ${D}/${sysconfdir}/matchbox
sed -f "$SCRIPT" ${S}/session > ${D}/${sysconfdir}/matchbox/session
chmod +x ${D}/${sysconfdir}/matchbox/session
-}
-
-pkg_postinst_${PN} () {
-#!/bin/sh -e
-if [ "x$D" != "x" ]; then
- exit 1
-fi
-. ${sysconfdir}/init.d/functions
-
-gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type string --set /desktop/poky/interface/theme Sato
-gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type string --set /desktop/poky/interface/icon_theme Sato
-gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type bool --set /desktop/poky/interface/touchscreen true
-gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type string --set /desktop/poky/interface/font_name "Sans 9"
+ install -d ${D}/${sysconfdir}/gconf/schemas
+ install -m 664 ${S}/matchbox-session-sato.schemas ${D}/${sysconfdir}/gconf/schemas
}
+
+inherit gconf