aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-rt/rt-tests/rt-tests_0.91.bb
diff options
context:
space:
mode:
authorMaxin B. John <maxin.john@enea.com>2015-03-20 18:07:56 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-04-02 12:01:40 +0100
commita7c5f3c921730655e0d0481882c61dac4933786f (patch)
treea5c90ed3c443b22b4dfb21808febfb4d31c65986 /meta/recipes-rt/rt-tests/rt-tests_0.91.bb
parentc30436b15a95d7ecec963a34ef88a18ff09f692b (diff)
downloadopenembedded-core-a7c5f3c921730655e0d0481882c61dac4933786f.tar.gz
rt-tests: bump version and enable ptest support
1. Upgrade version to 0.91 2. Add ptest support [YOCTO #1569] Signed-off-by: Thomas Lundström <thomas.lundstrom@enea.com> Signed-off-by: Maxin B. John <maxin.john@enea.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-rt/rt-tests/rt-tests_0.91.bb')
-rw-r--r--meta/recipes-rt/rt-tests/rt-tests_0.91.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-rt/rt-tests/rt-tests_0.91.bb b/meta/recipes-rt/rt-tests/rt-tests_0.91.bb
new file mode 100644
index 0000000000..fbe2f669e8
--- /dev/null
+++ b/meta/recipes-rt/rt-tests/rt-tests_0.91.bb
@@ -0,0 +1,30 @@
+SUMMARY = "Real-Time preemption testcases"
+HOMEPAGE = "https://rt.wiki.kernel.org/index.php/Cyclictest"
+SECTION = "tests"
+DEPENDS = "linux-libc-headers virtual/libc"
+LICENSE = "GPLv2 & GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
+ file://src/cyclictest/cyclictest.c;beginline=7;endline=9;md5=e768b8da44555fe63f65e5c497844cb5 \
+ file://src/pi_tests/pi_stress.c;beginline=6;endline=19;md5=bd426a634a43ec612e9fbf125dfcc949"
+
+require rt-tests.inc
+inherit ptest
+
+SRC_URI += "file://run-ptest \
+ file://rt_bmark.py \
+ "
+# Do not install hwlatdetect
+EXTRA_OEMAKE += "PYLIB=''"
+
+do_install() {
+ oe_runmake install DESTDIR=${D} SBINDIR=${sbindir} MANDIR=${mandir} \
+ INCLUDEDIR=${includedir}
+}
+
+do_install_ptest() {
+ cp ${WORKDIR}/rt_bmark.py ${D}${PTEST_PATH}
+}
+
+RDEPENDS_${PN}-ptest += " stress python python-subprocess python-multiprocessing python-datetime python-re python-lang"
+
+FILES_${PN} += "${prefix}/src/backfire"