aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-rt/rt-tests/hwlatdetect_0.91.bb
diff options
context:
space:
mode:
authorMaxin B. John <maxin.john@enea.com>2015-03-20 18:07:57 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-04-02 12:01:40 +0100
commitff8be8ab27586ffff1957904deccd8b8ec43b527 (patch)
tree9845980a607e3196bca20017b8d887a4a998c472 /meta/recipes-rt/rt-tests/hwlatdetect_0.91.bb
parenta7c5f3c921730655e0d0481882c61dac4933786f (diff)
downloadopenembedded-core-ff8be8ab27586ffff1957904deccd8b8ec43b527.tar.gz
hwlatdetect: upgrade to version 0.91
Upgrade hwlatdetect to version 0.91 Signed-off-by: Maxin B. John <maxin.john@enea.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-rt/rt-tests/hwlatdetect_0.91.bb')
-rw-r--r--meta/recipes-rt/rt-tests/hwlatdetect_0.91.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta/recipes-rt/rt-tests/hwlatdetect_0.91.bb b/meta/recipes-rt/rt-tests/hwlatdetect_0.91.bb
new file mode 100644
index 0000000000..8319eb987a
--- /dev/null
+++ b/meta/recipes-rt/rt-tests/hwlatdetect_0.91.bb
@@ -0,0 +1,23 @@
+SUMMARY = "Hardware latency detector"
+DESCRIPTION = "Python utility for controlling the kernel hardware latency detection module (hwlat_detector.ko)."
+HOMEPAGE = "http://git.kernel.org/?p=linux/kernel/git/clrkwllms/rt-tests.git"
+SECTION = "tests"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
+
+require rt-tests.inc
+
+EXTRA_OEMAKE += "PYLIB=${libdir}/python${PYTHON_BASEVERSION}/dist-packages"
+
+do_compile() {
+ oe_runmake hwlatdetect
+}
+
+do_install() {
+ oe_runmake install_hwlatdetect DESTDIR=${D} SBINDIR=${sbindir} \
+ MANDIR=${mandir} INCLUDEDIR=${includedir}
+}
+
+FILES_${PN} += "${libdir}/python${PYTHON_BASEVERSION}/dist-packages/hwlatdetect.py"
+RDEPENDS_${PN} = "python python-subprocess python-textutils"
+RRECOMMENDS_${PN} = "kernel-module-hwlat-detector"