aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-rt/rt-tests/hwlatdetect_0.89.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen.kooi@linaro.org>2014-06-17 11:01:28 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-06-17 10:23:45 +0100
commitcdbd772492812d2bd16ce9f3d5641910f9df240f (patch)
tree1e1a7cd121b03f9bad492f5b317cb0b8b4cbe3ba /meta/recipes-rt/rt-tests/hwlatdetect_0.89.bb
parent8f6e7a711b5b5ed23b270a385f9f491005ec32cf (diff)
downloadopenembedded-core-cdbd772492812d2bd16ce9f3d5641910f9df240f.tar.gz
hwlatdetect: fix PV
As an extra safety measure set PV in the same place as SRCREV. Signed-off-by: Koen Kooi <koen.kooi@linaro.org> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-rt/rt-tests/hwlatdetect_0.89.bb')
-rw-r--r--meta/recipes-rt/rt-tests/hwlatdetect_0.89.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta/recipes-rt/rt-tests/hwlatdetect_0.89.bb b/meta/recipes-rt/rt-tests/hwlatdetect_0.89.bb
new file mode 100644
index 0000000000..8319eb987a
--- /dev/null
+++ b/meta/recipes-rt/rt-tests/hwlatdetect_0.89.bb
@@ -0,0 +1,23 @@
+SUMMARY = "Hardware latency detector"
+DESCRIPTION = "Python utility for controlling the kernel hardware latency detection module (hwlat_detector.ko)."
+HOMEPAGE = "http://git.kernel.org/?p=linux/kernel/git/clrkwllms/rt-tests.git"
+SECTION = "tests"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
+
+require rt-tests.inc
+
+EXTRA_OEMAKE += "PYLIB=${libdir}/python${PYTHON_BASEVERSION}/dist-packages"
+
+do_compile() {
+ oe_runmake hwlatdetect
+}
+
+do_install() {
+ oe_runmake install_hwlatdetect DESTDIR=${D} SBINDIR=${sbindir} \
+ MANDIR=${mandir} INCLUDEDIR=${includedir}
+}
+
+FILES_${PN} += "${libdir}/python${PYTHON_BASEVERSION}/dist-packages/hwlatdetect.py"
+RDEPENDS_${PN} = "python python-subprocess python-textutils"
+RRECOMMENDS_${PN} = "kernel-module-hwlat-detector"