aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-rt/rt-tests/files/0001-rt-tests-Allow-for-user-specified-PYLIB.patch
diff options
context:
space:
mode:
authorGary S. Robertson <gary.robertson@linaro.org>2014-05-14 18:38:41 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-05-15 23:24:06 +0100
commit66daa92582a5a5643fd2e45aace1f5c009b2ded3 (patch)
tree37b42f53754b0f34ecd7e51bf66f539ab546e5f3 /meta/recipes-rt/rt-tests/files/0001-rt-tests-Allow-for-user-specified-PYLIB.patch
parentc5a52f5b5ae7c5528bc59ee7fb69a2f460a89b81 (diff)
downloadopenembedded-core-66daa92582a5a5643fd2e45aace1f5c009b2ded3.tar.gz
rt-tests: restore erroneously deleted patch files
Commit "rt-tests: bump version 0.87 => 0.89" (SHA1 ID: 7996ca) erroneously deleted several patch files which were still required for proper function of the rt-tests recipe. These missing patches adversely affected builds of the hwlatdetect and hackbench utilities as well as other components. This commit restores the missing patches and allows the recipe to properly generate all the components once more. hwlatdetect and hackbench are built properly and the /usr/src/backfire directory is properly populated on the target system. Signed-off-by: Gary S. Robertson <gary.robertson@linaro.org> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-rt/rt-tests/files/0001-rt-tests-Allow-for-user-specified-PYLIB.patch')
-rw-r--r--meta/recipes-rt/rt-tests/files/0001-rt-tests-Allow-for-user-specified-PYLIB.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta/recipes-rt/rt-tests/files/0001-rt-tests-Allow-for-user-specified-PYLIB.patch b/meta/recipes-rt/rt-tests/files/0001-rt-tests-Allow-for-user-specified-PYLIB.patch
new file mode 100644
index 0000000000..8b493eb1f1
--- /dev/null
+++ b/meta/recipes-rt/rt-tests/files/0001-rt-tests-Allow-for-user-specified-PYLIB.patch
@@ -0,0 +1,35 @@
+From 66765522b634952346f1a3ab7d00c7222a1f9361 Mon Sep 17 00:00:00 2001
+Message-Id: <66765522b634952346f1a3ab7d00c7222a1f9361.1347419597.git.dvhart@linux.intel.com>
+From: Darren Hart <dvhart@linux.intel.com>
+Date: Tue, 11 Sep 2012 15:19:30 -0700
+Subject: [PATCH 1/2] rt-tests: Allow for user-specified PYLIB
+
+Upstream-Status: Submitted
+
+Allow users (build systems) to specify PYLIB. This allows for a
+cross-build-system to specify the target PYLIB rather than the host
+PYLIB.
+
+Signed-off-by: Darren Hart <dvhart@linux.intel.com>
+CC: Clark Williams <williams@redhat.com>
+CC: John Kacur <jkacur@redhat.com>
+---
+ Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index 3a82407..61e2f9f 100644
+--- a/Makefile
++++ b/Makefile
+@@ -23,7 +23,7 @@ endif
+ CFLAGS ?= -D_GNU_SOURCE -Wall -Wno-nonnull -Isrc/include
+ LDFLAGS ?=
+
+-PYLIB := $(shell python -c 'import distutils.sysconfig; print distutils.sysconfig.get_python_lib()')
++PYLIB ?= $(shell python -c 'import distutils.sysconfig; print distutils.sysconfig.get_python_lib()')
+
+ ifndef DEBUG
+ CFLAGS += -O2
+--
+1.7.11.4
+