summaryrefslogtreecommitdiffstats
path: root/meta/recipes-qt
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-02-08 13:21:59 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-02-28 12:14:48 +0000
commitf29bb5b2a99ecef46e5570bf3336e9680c0b6705 (patch)
tree1a6152a39c1d7a14c15ca5d812dd89760a4e1956 /meta/recipes-qt
parentc700c2c8dea6d79e718c831d4659ce69f0b6a7e2 (diff)
downloadopenembedded-core-f29bb5b2a99ecef46e5570bf3336e9680c0b6705.tar.gz
qt4: fix compile error in Qt 4.8.0 with gcc 4.6
Ensure the Qt configure script can can detect the compiler correctly as g++. This fixes the following compile error with gcc 4.6: ./wtf/NullPtr.h:48:1: error: identifier 'nullptr' will become a keyword in C++0x [-Werror=c++0x-compat] Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'meta/recipes-qt')
-rw-r--r--meta/recipes-qt/qt4/qt-4.8.0.inc1
-rw-r--r--meta/recipes-qt/qt4/qt-4.8.0/configure_oe_compiler.patch31
-rw-r--r--meta/recipes-qt/qt4/qt4-embedded_4.8.0.bb2
3 files changed, 33 insertions, 1 deletions
diff --git a/meta/recipes-qt/qt4/qt-4.8.0.inc b/meta/recipes-qt/qt4/qt-4.8.0.inc
index 2addbb211f..532f1ff40c 100644
--- a/meta/recipes-qt/qt4/qt-4.8.0.inc
+++ b/meta/recipes-qt/qt4/qt-4.8.0.inc
@@ -14,6 +14,7 @@ SRC_URI = "http://get.qt.nokia.com/qt/source/qt-everywhere-opensource-src-${PV}.
file://fix-translations.patch \
file://add_nostrip_for_debug_packages.diff \
file://qmake_cxx_eval.patch \
+ file://configure_oe_compiler.patch \
file://g++.conf \
file://linux.conf \
"
diff --git a/meta/recipes-qt/qt4/qt-4.8.0/configure_oe_compiler.patch b/meta/recipes-qt/qt4/qt-4.8.0/configure_oe_compiler.patch
new file mode 100644
index 0000000000..d455d0acfe
--- /dev/null
+++ b/meta/recipes-qt/qt4/qt-4.8.0/configure_oe_compiler.patch
@@ -0,0 +1,31 @@
+Ensure we identify the compiler as g++ in configure
+
+Our PLATFORM in OE is ${TARGET_OS}-oe-g++, and previously the configure
+script was interpreting from this that the compiler was "oe-g++" and thus
+g++ specific checks were not being run since this string did not match;
+among other things this resulted in a compiler version check in the
+QtWebKit build code not working, and hence the following error at build
+time:
+
+./wtf/NullPtr.h:48:1: error: identifier 'nullptr' will become a keyword in C++0x [-Werror=c++0x-compat]
+
+The easiest thing since our PLATFORM is entirely artificial is to just
+force COMPILER to "g++" in the configure script if it is detected as
+"oe-g++".
+
+Upstream-Status: Inappropriate [configuration]
+
+Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
+
+--- qt-everywhere-opensource-src-4.8.0.orig/configure
++++ qt-everywhere-opensource-src-4.8.0/configure
+@@ -7444,6 +7444,9 @@ elif [ "$XPLATFORM" != "$PLATFORM" ]; th
+ else
+ COMPILER=`echo $PLATFORM | cut -f 2- -d-`
+ fi
++case $COMPILER in
++ *oe-g++) COMPILER="g++" ;;
++esac
+ if [ "$CFG_EXCEPTIONS" = "unspecified" -a "$PLATFORM_QWS" = "yes" ]; then
+ CFG_EXCEPTIONS=no
+ fi
diff --git a/meta/recipes-qt/qt4/qt4-embedded_4.8.0.bb b/meta/recipes-qt/qt4/qt4-embedded_4.8.0.bb
index 5c1c97eeac..efbc02ae03 100644
--- a/meta/recipes-qt/qt4/qt4-embedded_4.8.0.bb
+++ b/meta/recipes-qt/qt4/qt4-embedded_4.8.0.bb
@@ -1,7 +1,7 @@
require qt-${PV}.inc
require qt4-embedded.inc
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
DEFAULT_PREFERENCE = "-1"