summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2019-07-03 10:41:57 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-11-07 11:45:25 +0000
commitae6e7dd19b6da81090a38792dfdf31b459290466 (patch)
treec32a4098e0caaf7a23f9c2a60c7d09b7fff9278b /meta/recipes-multimedia
parent3d3bd7952cf4bf5c94e4d18b45a604b95b69e8c3 (diff)
downloadopenembedded-core-ae6e7dd19b6da81090a38792dfdf31b459290466.tar.gz
dhcp/ruby/ffpmeg: Use CFLAGS, not TARGET_CFLAGS
There isn't anything specific about the target in these cases an in general recipes should touch CFLAGS. This ensures people don't copy/paste bad example usages. In reality, behaviour is mostly unchanged. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-multimedia')
-rw-r--r--meta/recipes-multimedia/ffmpeg/ffmpeg_4.2.1.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-multimedia/ffmpeg/ffmpeg_4.2.1.bb b/meta/recipes-multimedia/ffmpeg/ffmpeg_4.2.1.bb
index ec306afaaa..5ac18ba3f1 100644
--- a/meta/recipes-multimedia/ffmpeg/ffmpeg_4.2.1.bb
+++ b/meta/recipes-multimedia/ffmpeg/ffmpeg_4.2.1.bb
@@ -102,8 +102,8 @@ EXTRA_OECONF = " \
--arch=${TARGET_ARCH} \
--target-os="linux" \
--enable-cross-compile \
- --extra-cflags="${TARGET_CFLAGS} ${HOST_CC_ARCH}${TOOLCHAIN_OPTIONS}" \
- --extra-ldflags="${TARGET_LDFLAGS}" \
+ --extra-cflags="${CFLAGS} ${HOST_CC_ARCH}${TOOLCHAIN_OPTIONS}" \
+ --extra-ldflags="${LDFLAGS}" \
--sysroot="${STAGING_DIR_TARGET}" \
${EXTRA_FFCONF} \
--libdir=${libdir} \