aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia
diff options
context:
space:
mode:
authorAndre McCurdy <armccurdy@gmail.com>2017-01-12 15:52:32 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-01-19 22:45:43 +0000
commita41129815bc46460d145208113a8b75a92f3d19d (patch)
tree6a3ad536ceb647ee47100f3fd22bdfa9f30c23b9 /meta/recipes-multimedia
parente37e023da9833fc6d17a8a57554aaf986b4e8d56 (diff)
downloadopenembedded-core-a41129815bc46460d145208113a8b75a92f3d19d.tar.gz
gstreamer1.0-plugins-good: fix qtdemux_parse_svq3_stsd_data() memory leak
Backport from 1.11.1 https://cgit.freedesktop.org/gstreamer/gst-plugins-good/commit/?id=29433495d697e4dcb3bc50ff0e0d866acb949890 Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-multimedia')
-rw-r--r--meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good/qtdemux-free-seqh-after-calling-qtdemux_parse_svq3_s.patch33
-rw-r--r--meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.10.2.bb1
2 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good/qtdemux-free-seqh-after-calling-qtdemux_parse_svq3_s.patch b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good/qtdemux-free-seqh-after-calling-qtdemux_parse_svq3_s.patch
new file mode 100644
index 0000000000..3428790003
--- /dev/null
+++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good/qtdemux-free-seqh-after-calling-qtdemux_parse_svq3_s.patch
@@ -0,0 +1,33 @@
+From 29433495d697e4dcb3bc50ff0e0d866acb949890 Mon Sep 17 00:00:00 2001
+From: Andre McCurdy <armccurdy@gmail.com>
+Date: Wed, 11 Jan 2017 17:53:32 -0800
+Subject: [PATCH] qtdemux: free seqh after calling
+ qtdemux_parse_svq3_stsd_data()
+
+The seqh buffer allocated in qtdemux_parse_svq3_stsd_data() needs to
+be freed by the caller after use.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=777157
+
+Upstream-Status: Backport
+
+Signed-off-by: Andre McCurdy <armccurdy@gmail.com>
+---
+ gst/isomp4/qtdemux.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/gst/isomp4/qtdemux.c b/gst/isomp4/qtdemux.c
+index e105809..7a431e0 100644
+--- a/gst/isomp4/qtdemux.c
++++ b/gst/isomp4/qtdemux.c
+@@ -10375,6 +10375,7 @@ qtdemux_parse_trak (GstQTDemux * qtdemux, GNode * trak)
+ * than its own fourcc */
+ gst_caps_set_simple (stream->caps, "seqh", GST_TYPE_BUFFER, seqh,
+ NULL);
++ gst_buffer_unref (seqh);
+ }
+
+ GST_DEBUG_OBJECT (qtdemux, "found codec_data in stsd");
+--
+1.9.1
+
diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.10.2.bb b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.10.2.bb
index 18262d0bfd..6c119e5c76 100644
--- a/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.10.2.bb
+++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.10.2.bb
@@ -10,6 +10,7 @@ SRC_URI = " \
file://avoid-including-sys-poll.h-directly.patch \
file://ensure-valid-sentinel-for-gst_structure_get.patch \
file://0001-introspection.m4-prefix-pkgconfig-paths-with-PKG_CON.patch \
+ file://qtdemux-free-seqh-after-calling-qtdemux_parse_svq3_s.patch \
"
SRC_URI[md5sum] = "65c4ff9d406c3ea9383b4d38a6504349"
SRC_URI[sha256sum] = "198f325bcce982dce1ebeb36929a5f430b8bf9528e0d519e18df0b29e1d23313"