summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2011-04-30 11:19:59 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-05-04 00:52:59 +0100
commit199e76cd3d3bafef189d5a82e65796fb4a0c6536 (patch)
treeff65b77b260fc0774d03e2f471e90b8e34ea87a2 /meta/recipes-multimedia
parent9cf807f53af988f42ef7742ead58f78bcb869c10 (diff)
downloadopenembedded-core-199e76cd3d3bafef189d5a82e65796fb4a0c6536.tar.gz
alsa-utils_1.0.24.2.bb: Fix build for uclibc targets
uclibc does not have exp10() implemented so we obtain same behaviour using pow() Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta/recipes-multimedia')
-rw-r--r--meta/recipes-multimedia/alsa/alsa-utils-1.0.24.2/uclibc-exp10-replacement.patch21
-rw-r--r--meta/recipes-multimedia/alsa/alsa-utils_1.0.24.2.bb4
2 files changed, 24 insertions, 1 deletions
diff --git a/meta/recipes-multimedia/alsa/alsa-utils-1.0.24.2/uclibc-exp10-replacement.patch b/meta/recipes-multimedia/alsa/alsa-utils-1.0.24.2/uclibc-exp10-replacement.patch
new file mode 100644
index 0000000000..038c90d600
--- /dev/null
+++ b/meta/recipes-multimedia/alsa/alsa-utils-1.0.24.2/uclibc-exp10-replacement.patch
@@ -0,0 +1,21 @@
+uclibc does not have exp10 function which is glibc extension.
+Bur we can get the same behavior by using pow()
+
+Upstream-status: Pending
+
+Khem Raj <raj.khem@gmail.com>
+
+Index: alsa-utils-1.0.24.2/alsamixer/volume_mapping.c
+===================================================================
+--- alsa-utils-1.0.24.2.orig/alsamixer/volume_mapping.c
++++ alsa-utils-1.0.24.2/alsamixer/volume_mapping.c
+@@ -36,6 +36,9 @@
+ #include <math.h>
+ #include <stdbool.h>
+ #include "volume_mapping.h"
++#ifdef __UCLIBC__
++#define exp10(x) (pow(10, (x)))
++#endif /* __UCLIBC__ */
+
+ #define MAX_LINEAR_DB_SCALE 24
+
diff --git a/meta/recipes-multimedia/alsa/alsa-utils_1.0.24.2.bb b/meta/recipes-multimedia/alsa/alsa-utils_1.0.24.2.bb
index c882bfd57f..4cb31a9547 100644
--- a/meta/recipes-multimedia/alsa/alsa-utils_1.0.24.2.bb
+++ b/meta/recipes-multimedia/alsa/alsa-utils_1.0.24.2.bb
@@ -9,7 +9,9 @@ DEPENDS = "alsa-lib ncurses"
PR = "r0"
SRC_URI = "ftp://ftp.alsa-project.org/pub/utils/alsa-utils-${PV}.tar.bz2 \
- file://ncursesfix.patch"
+ file://ncursesfix.patch \
+ file://uclibc-exp10-replacement.patch \
+ "
SRC_URI[md5sum] = "8238cd57cb301d1c36bcf0ecb59ce6b2"
SRC_URI[sha256sum] = "95127f740291086486c06c28118cabca0814bde48fd14dac041a9812a5ac1be2"