summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2012-06-07 15:59:46 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-06-08 11:55:57 +0100
commitd3dc05a4b808136876cb257a568737abfaceeadd (patch)
tree6faf6fe4bb21fd0448087d48e1d1490061ddf406 /meta/recipes-kernel
parent96ae45be42dcab338e9f8e3aebd2217146a79f87 (diff)
downloadopenembedded-core-d3dc05a4b808136876cb257a568737abfaceeadd.tar.gz
linux-yocto: add machine aliases for yocto BSPs
To avoid mapping machine names to kernel machine names in recipes, we can define multiple KMACHINE names for a single in tree board. This allows the tools to match a board description to multiple different MACHINEs. As a result, we can remove the explicit KMACHINE mappings from the linux-yocto recipes and allow the KMACHINE=${MACHINE} default to handle mappings. Individual recipes an bbappends can override this as required. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_3.0.bb9
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_3.2.bb9
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_3.2.bb3
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_3.0.bb9
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_3.2.bb9
5 files changed, 5 insertions, 34 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_3.0.bb b/meta/recipes-kernel/linux/linux-yocto-rt_3.0.bb
index 929aa8503a..508beb1768 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_3.0.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_3.0.bb
@@ -1,13 +1,6 @@
inherit kernel
require recipes-kernel/linux/linux-yocto.inc
-KMACHINE = "common-pc"
-KMACHINE_qemux86 = "common-pc"
-KMACHINE_qemux86-64 = "common-pc-64"
-KMACHINE_qemuarm = "arm-versatile-926ejs"
-KMACHINE_qemuppc = "qemu-ppc32"
-KMACHINE_qemumips = "mti-malta32-be"
-
KBRANCH = "yocto/standard/preempt-rt/base"
KBRANCH_qemuppc = "yocto/standard/preempt-rt/qemu-ppc32"
@@ -17,7 +10,7 @@ KMETA = "meta"
SRCREV_machine ?= "e67428d9966eecec4c081993dc64ceb5c0e64643"
SRCREV_machine_qemuppc ?= "dcca458cb92cc287f70e4062f02460f36a881b16"
-SRCREV_meta ?= "34e0d2b4b4e9778b31f9ea99ca43f0dc71a7ee23"
+SRCREV_meta ?= "b040132c19d70b00fc49f3b7e08c2ed52ac59f92"
PR = "r2"
PV = "${LINUX_VERSION}+git${SRCPV}"
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_3.2.bb b/meta/recipes-kernel/linux/linux-yocto-rt_3.2.bb
index f881c1f2f6..f27e39e73e 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_3.2.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_3.2.bb
@@ -1,13 +1,6 @@
inherit kernel
require recipes-kernel/linux/linux-yocto.inc
-KMACHINE = "common-pc"
-KMACHINE_qemux86 = "common-pc"
-KMACHINE_qemux86-64 = "common-pc-64"
-KMACHINE_qemuarm = "arm-versatile-926ejs"
-KMACHINE_qemuppc = "qemu-ppc32"
-KMACHINE_qemumips = "mti-malta32-be"
-
KBRANCH = "standard/preempt-rt/base"
KBRANCH_qemuppc = "standard/preempt-rt/qemu-ppc32"
@@ -18,7 +11,7 @@ KMETA = "meta"
SRCREV_machine ?= "fe2630b38159ea7b9cf977b5fed40a9917002087"
SRCREV_machine_qemuppc ?= "0259e5a3ef568c6979f2cb31280a43c55c784f4f"
-SRCREV_meta ?= "49f931bc294d5b6be60502bbd448cff5aa766235"
+SRCREV_meta ?= "0a18db9fc89a0e030e8c7b8d01fe03c5ca4197e3"
PR = "r1"
PV = "${LINUX_VERSION}+git${SRCPV}"
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_3.2.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_3.2.bb
index 80be112ac3..81aefb169d 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_3.2.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_3.2.bb
@@ -4,7 +4,6 @@ require recipes-kernel/linux/linux-yocto.inc
# We need lzma (as CONFIG_KERNEL_LZMA=y)
DEPENDS += "xz-native"
-KMACHINE = "common-pc"
KBRANCH = "standard/tiny"
LINUX_KERNEL_TYPE = "tiny"
KCONFIG_MODE = "--allnoconfig"
@@ -12,7 +11,7 @@ KCONFIG_MODE = "--allnoconfig"
LINUX_VERSION ?= "3.2.18"
SRCREV_machine ?= "8b8cfaaab2b8d79ac56e8c9a85bad9ae7bca399c"
-SRCREV_meta ?= "49f931bc294d5b6be60502bbd448cff5aa766235"
+SRCREV_meta ?= "0a18db9fc89a0e030e8c7b8d01fe03c5ca4197e3"
PR = "r0"
PV = "${LINUX_VERSION}+git${SRCPV}"
diff --git a/meta/recipes-kernel/linux/linux-yocto_3.0.bb b/meta/recipes-kernel/linux/linux-yocto_3.0.bb
index 0f1be83967..cfae247866 100644
--- a/meta/recipes-kernel/linux/linux-yocto_3.0.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_3.0.bb
@@ -8,13 +8,6 @@ KBRANCH_qemuppc = "yocto/standard/qemu-ppc32"
KBRANCH_qemumips = "yocto/standard/mti-malta32-be"
KBRANCH_qemuarm = "yocto/standard/arm-versatile-926ejs"
-# Temporary until 3.0 kernel tree is updated with machine mappings
-KMACHINE_qemux86 = "common-pc"
-KMACHINE_qemux86-64 = "common-pc-64"
-KMACHINE_qemuppc = "qemu-ppc32"
-KMACHINE_qemumips = "mti-malta32-be"
-KMACHINE_qemuarm = "arm-versatile-926ejs"
-
KMETA = "meta"
LINUX_VERSION ?= "3.0.32"
@@ -25,7 +18,7 @@ SRCREV_machine_qemuppc ?= "bd9a3c4c066bd4b9f52b51aaaec9b029a7abe793"
SRCREV_machine_qemux86 ?= "70342faea067476774eb55f4e3098af0bcc48782"
SRCREV_machine_qemux86-64 ?= "cba836a545fbeb96f6f2392c3ecbac9d7735fa65"
SRCREV_machine ?= "bd6ad607c754dea30d91502a237870b4c45e0f1b"
-SRCREV_meta ?= "34e0d2b4b4e9778b31f9ea99ca43f0dc71a7ee23"
+SRCREV_meta ?= "b040132c19d70b00fc49f3b7e08c2ed52ac59f92"
PR = "r4"
PV = "${LINUX_VERSION}+git${SRCPV}"
diff --git a/meta/recipes-kernel/linux/linux-yocto_3.2.bb b/meta/recipes-kernel/linux/linux-yocto_3.2.bb
index 665ddca053..ac4e454702 100644
--- a/meta/recipes-kernel/linux/linux-yocto_3.2.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_3.2.bb
@@ -1,13 +1,6 @@
inherit kernel
require recipes-kernel/linux/linux-yocto.inc
-KMACHINE = "common-pc"
-KMACHINE_qemux86 = "common-pc"
-KMACHINE_qemux86-64 = "common-pc-64"
-KMACHINE_qemuppc = "qemu-ppc32"
-KMACHINE_qemumips = "mti-malta32-be"
-KMACHINE_qemuarm = "arm-versatile-926ejs"
-
KBRANCH = "standard/default/base"
KBRANCH_qemux86 = "standard/default/common-pc/base"
KBRANCH_qemux86-64 = "standard/default/common-pc-64/base"
@@ -23,7 +16,7 @@ SRCREV_machine_qemuppc ?= "466746d1fe6370957ba087f9ca6f2e31201b2162"
SRCREV_machine_qemux86 ?= "c228cadee60f0ada73d11a36f6932f50a1c52d48"
SRCREV_machine_qemux86-64 ?= "b95a0ae3773545fa0ed9a47088d0361527c42e6c"
SRCREV_machine ?= "8b8cfaaab2b8d79ac56e8c9a85bad9ae7bca399c"
-SRCREV_meta ?= "49f931bc294d5b6be60502bbd448cff5aa766235"
+SRCREV_meta ?= "0a18db9fc89a0e030e8c7b8d01fe03c5ca4197e3"
PR = "r1"
PV = "${LINUX_VERSION}+git${SRCPV}"