summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2012-06-20 10:31:41 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-06-21 12:46:20 +0100
commitb485f3e0e55ad62079ed0913970ff0620f4808ea (patch)
tree1589e2268531825c7d3ed6458e92e2bfb14c61e7 /meta/recipes-kernel
parentab883d0c1a05bd99e97e5d71bc7bed05cb1ae8c8 (diff)
downloadopenembedded-core-b485f3e0e55ad62079ed0913970ff0620f4808ea.tar.gz
recipes-kernel: remove linux-tools.inc
perf has been moved to a standalone package, making linux-tools.inc unecessary. It can now be removed and recipes that included it updated. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel')
-rw-r--r--meta/recipes-kernel/linux/linux-tools.inc41
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_3.0.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_3.2.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_3.4.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_3.0.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_3.2.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_3.4.bb2
7 files changed, 0 insertions, 53 deletions
diff --git a/meta/recipes-kernel/linux/linux-tools.inc b/meta/recipes-kernel/linux/linux-tools.inc
deleted file mode 100644
index 3b03c05167..0000000000
--- a/meta/recipes-kernel/linux/linux-tools.inc
+++ /dev/null
@@ -1,41 +0,0 @@
-# included by kernel recipes if they want to build/provide
-# perf functionality from their tree.
-
-BUILDPERF = "yes"
-BUILDPERF_libc-uclibc = "no"
-# perf requires binutils which is GPLv3 licensed, don't prevent the entire kernel
-# being built if GPLv3 is in INCOMPATIBLE_LICENSE
-python () {
- if ((d.getVar("INCOMPATIBLE_LICENSE", True) or "").find("GPLv3") != -1):
- # GPLv3, drop perf
- d.setVar("BUILDPERF", "no")
- d.setVar("PERFDEPENDS", "")
-}
-
-do_compile_perf () {
- if [ "${BUILDPERF}" = "yes" ]; then
- oe_runmake -C ${S}/tools/perf CC="${CC}" LD="${LD}" prefix=${prefix} NO_NEWT=1 NO_DWARF=1
- fi
-}
-
-fakeroot do_install_perf () {
- if [ "${BUILDPERF}" = "yes" ]; then
- oe_runmake -C ${S}/tools/perf CC="${CC}" LD="${LD}" prefix=${prefix} DESTDIR=${D} install NO_NEWT=1 NO_DWARF=1
- fi
-}
-
-
-# perf tasks
-addtask compile_perf after do_compile before do_install
-addtask install_perf after do_install before do_package
-
-do_compile_perf[umask] = "022"
-do_install_perf[umask] = "022"
-
-PERFDEPENDS = "virtual/${MLPREFIX}libc:do_populate_sysroot ${MLPREFIX}elfutils:do_populate_sysroot ${MLPREFIX}binutils:do_populate_sysroot"
-PERFDEPENDS_libc-uclibc = ""
-PERFRDEPENDS = "python perl elfutils"
-PERFRDEPENDS_libc-uclibc = ""
-
-do_compile_perf[depends] = "${PERFDEPENDS}"
-RDEPENDS_perf += "${PERFRDEPENDS}"
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_3.0.bb b/meta/recipes-kernel/linux/linux-yocto-rt_3.0.bb
index a39b9663e8..971d1a8901 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_3.0.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_3.0.bb
@@ -27,5 +27,3 @@ KERNEL_FEATURES = "features/netfilter"
KERNEL_FEATURES_append = " features/taskstats"
KERNEL_FEATURES_append_qemux86 = " cfg/sound"
KERNEL_FEATURES_append_qemux86-64 = " cfg/sound"
-
-require recipes-kernel/linux/linux-tools.inc
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_3.2.bb b/meta/recipes-kernel/linux/linux-yocto-rt_3.2.bb
index a07b27acfb..ada66b8a17 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_3.2.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_3.2.bb
@@ -28,5 +28,3 @@ KERNEL_FEATURES = "features/netfilter"
KERNEL_FEATURES_append = " features/taskstats"
KERNEL_FEATURES_append_qemux86 = " cfg/sound"
KERNEL_FEATURES_append_qemux86-64 = " cfg/sound"
-
-require recipes-kernel/linux/linux-tools.inc
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_3.4.bb b/meta/recipes-kernel/linux/linux-yocto-rt_3.4.bb
index 81730ea085..52f2dd1d6c 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_3.4.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_3.4.bb
@@ -28,5 +28,3 @@ KERNEL_FEATURES = "features/netfilter"
KERNEL_FEATURES_append = " features/taskstats"
KERNEL_FEATURES_append_qemux86 = " cfg/sound"
KERNEL_FEATURES_append_qemux86-64 = " cfg/sound"
-
-require recipes-kernel/linux/linux-tools.inc
diff --git a/meta/recipes-kernel/linux/linux-yocto_3.0.bb b/meta/recipes-kernel/linux/linux-yocto_3.0.bb
index 440821ca94..5cdff95fdc 100644
--- a/meta/recipes-kernel/linux/linux-yocto_3.0.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_3.0.bb
@@ -32,5 +32,3 @@ KERNEL_FEATURES = "features/netfilter"
KERNEL_FEATURES_append = " features/taskstats"
KERNEL_FEATURES_append_qemux86 = " cfg/sound"
KERNEL_FEATURES_append_qemux86-64 = " cfg/sound"
-
-require linux-tools.inc
diff --git a/meta/recipes-kernel/linux/linux-yocto_3.2.bb b/meta/recipes-kernel/linux/linux-yocto_3.2.bb
index e6cf9bb678..3e4a9dded1 100644
--- a/meta/recipes-kernel/linux/linux-yocto_3.2.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_3.2.bb
@@ -32,5 +32,3 @@ KERNEL_FEATURES="features/netfilter"
KERNEL_FEATURES_append=" features/taskstats"
KERNEL_FEATURES_append_qemux86=" cfg/sound"
KERNEL_FEATURES_append_qemux86-64=" cfg/sound"
-
-require linux-tools.inc
diff --git a/meta/recipes-kernel/linux/linux-yocto_3.4.bb b/meta/recipes-kernel/linux/linux-yocto_3.4.bb
index af6130df71..eb5e8888b7 100644
--- a/meta/recipes-kernel/linux/linux-yocto_3.4.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_3.4.bb
@@ -34,5 +34,3 @@ KERNEL_REVISION_CHECKING=""
KERNEL_FEATURES="features/netfilter"
KERNEL_FEATURES_append_qemux86=" cfg/sound"
KERNEL_FEATURES_append_qemux86-64=" cfg/sound"
-
-require recipes-kernel/linux/linux-tools.inc