summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2018-08-28 16:43:58 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-08-29 10:40:08 +0100
commit3d92bce5a8e021c03e509e8ee6ead064e97bfcec (patch)
tree1f5e6bac1d0907b290bb500abad591c0c023ffbe /meta/recipes-kernel
parent5f3ab95b0ed964e08c65ae3159606f27485dbec7 (diff)
downloadopenembedded-core-3d92bce5a8e021c03e509e8ee6ead064e97bfcec.tar.gz
kmod: do not reset $bindir/sbindir, use EXTRA_OECONF instead
This was causing issues with classes that use $bindir to find already installed binaries in rootfs (manpages class in particular). $bindir needs to be the same for all recipes. Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel')
-rw-r--r--meta/recipes-kernel/kmod/kmod_git.bb4
1 files changed, 1 insertions, 3 deletions
diff --git a/meta/recipes-kernel/kmod/kmod_git.bb b/meta/recipes-kernel/kmod/kmod_git.bb
index 69185b2453..b25679359b 100644
--- a/meta/recipes-kernel/kmod/kmod_git.bb
+++ b/meta/recipes-kernel/kmod/kmod_git.bb
@@ -13,9 +13,7 @@ RREPLACES_${PN} += "module-init-tools-insmod-static module-init-tools-depmod mod
RCONFLICTS_libkmod2 += "module-init-tools-insmod-static module-init-tools-depmod module-init-tools"
# autotools set prefix to /usr, however we want them in /bin and /sbin
-bindir = "${base_bindir}"
-sbindir = "${base_sbindir}"
-# libdir = "${base_libdir}"
+EXTRA_OECONF += " --bindir=${base_bindir} --sbindir=${base_sbindir}"
do_install_append () {
install -dm755 ${D}${base_bindir}