summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel
diff options
context:
space:
mode:
authorTom Zanussi <tom.zanussi@intel.com>2012-07-12 07:17:11 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-07-12 12:51:21 +0100
commit1b40dac2c501ae8c8d812cf2866fe7917f144a19 (patch)
tree18167c21f15e08f37e46e016a17d4424e529c9a8 /meta/recipes-kernel
parent20405bdab18b7a2b101f818e72863d289d5945e4 (diff)
downloadopenembedded-core-1b40dac2c501ae8c8d812cf2866fe7917f144a19.tar.gz
perf: add perl, python to DEPENDS
perf has perl and python compile-time dependendencies, add them. Signed-off-by: Tom Zanussi <tom.zanussi@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel')
-rw-r--r--meta/recipes-kernel/perf/perf_3.4.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta/recipes-kernel/perf/perf_3.4.bb b/meta/recipes-kernel/perf/perf_3.4.bb
index ccb7425135..5bdd924839 100644
--- a/meta/recipes-kernel/perf/perf_3.4.bb
+++ b/meta/recipes-kernel/perf/perf_3.4.bb
@@ -9,19 +9,21 @@ as well."
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
-PR = "r3"
+PR = "r4"
require perf.inc
BUILDPERF_libc-uclibc = "no"
TUI_DEPENDS = "${@perf_feature_enabled('perf-tui', 'libnewt', '',d)}"
+SCRIPTING_DEPENDS = "${@perf_feature_enabled('perf-scripting', 'perl python', '',d)}"
DEPENDS = "virtual/kernel \
virtual/${MLPREFIX}libc \
${MLPREFIX}elfutils \
${MLPREFIX}binutils \
${TUI_DEPENDS} \
+ ${SCRIPTING_DEPENDS} \
"
SCRIPTING_RDEPENDS = "${@perf_feature_enabled('perf-scripting', 'perl perl-modules python', '',d)}"