aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2014-06-02 21:04:59 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-06-03 16:45:04 +0100
commit2543b14dd0ca13005be0df027543431fc8e882ae (patch)
tree003ed12714ff59d4be59dcbf311d8cf1a73672fe /meta/recipes-kernel
parent0ced649c055dd25c500d0fd34e4ea94504d98580 (diff)
downloadopenembedded-core-2543b14dd0ca13005be0df027543431fc8e882ae.tar.gz
recipes: Add missing pkgconfig class inherits
These recipes all use pkg-config in some way but were missing dependencies on the tool, this patch adds them. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel')
-rw-r--r--meta/recipes-kernel/lttng/babeltrace_1.2.1.bb2
-rw-r--r--meta/recipes-kernel/oprofile/oprofile.inc2
-rw-r--r--meta/recipes-kernel/powertop/powertop_2.5.bb2
-rw-r--r--meta/recipes-kernel/sysprof/sysprof_git.bb2
4 files changed, 4 insertions, 4 deletions
diff --git a/meta/recipes-kernel/lttng/babeltrace_1.2.1.bb b/meta/recipes-kernel/lttng/babeltrace_1.2.1.bb
index 542491b645..a8ea4cb213 100644
--- a/meta/recipes-kernel/lttng/babeltrace_1.2.1.bb
+++ b/meta/recipes-kernel/lttng/babeltrace_1.2.1.bb
@@ -6,7 +6,7 @@ BUGTRACKER = "https://bugs.lttng.org/projects/babeltrace"
LICENSE = "MIT & GPLv2"
LIC_FILES_CHKSUM = "file://LICENSE;md5=76ba15dd76a248e1dd526bca0e2125fa"
-inherit autotools
+inherit autotools pkgconfig
DEPENDS = "glib-2.0 util-linux popt"
diff --git a/meta/recipes-kernel/oprofile/oprofile.inc b/meta/recipes-kernel/oprofile/oprofile.inc
index e431071283..ccf9f9fa61 100644
--- a/meta/recipes-kernel/oprofile/oprofile.inc
+++ b/meta/recipes-kernel/oprofile/oprofile.inc
@@ -22,7 +22,7 @@ SRC_URI = "file://opstart.patch \
file://oprofile-root.patch \
file://acinclude.m4"
-inherit autotools-brokensep
+inherit autotools-brokensep pkgconfig
EXTRA_OECONF = "--with-kernel=${STAGING_KERNEL_DIR} --without-x"
do_configure () {
diff --git a/meta/recipes-kernel/powertop/powertop_2.5.bb b/meta/recipes-kernel/powertop/powertop_2.5.bb
index f37d7a76e0..86a7f604de 100644
--- a/meta/recipes-kernel/powertop/powertop_2.5.bb
+++ b/meta/recipes-kernel/powertop/powertop_2.5.bb
@@ -11,7 +11,7 @@ SRC_URI = "http://01.org/powertop/sites/default/files/downloads/powertop-${PV}.t
SRC_URI[md5sum] = "806bbcbd44fcea1f807c9582fc1f7d3e"
SRC_URI[sha256sum] = "8b2c08a555d79e1c428863470c41cb023971d74ba4801d80a05e35adeec23c0b"
-inherit autotools gettext
+inherit autotools gettext pkgconfig
# we need to explicitly link with libintl in uClibc systems
LDFLAGS += "${EXTRA_LDFLAGS}"
diff --git a/meta/recipes-kernel/sysprof/sysprof_git.bb b/meta/recipes-kernel/sysprof/sysprof_git.bb
index 73e617f219..ef1e270883 100644
--- a/meta/recipes-kernel/sysprof/sysprof_git.bb
+++ b/meta/recipes-kernel/sysprof/sysprof_git.bb
@@ -17,4 +17,4 @@ SRC_URI_append_mips64 = " file://rmb-mips.patch"
S = "${WORKDIR}/git"
-inherit autotools
+inherit autotools pkgconfig