aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/modutils/modutils_2.4.27.bb
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:14:24 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:29:45 +0100
commit29d6678fd546377459ef75cf54abeef5b969b5cf (patch)
tree8edd65790e37a00d01c3f203f773fe4b5012db18 /meta/recipes-kernel/modutils/modutils_2.4.27.bb
parentda49de6885ee1bc424e70bc02f21f6ab920efb55 (diff)
downloadopenembedded-core-29d6678fd546377459ef75cf54abeef5b969b5cf.tar.gz
Major layout change to the packages directory
Having one monolithic packages directory makes it hard to find things and is generally overwhelming. This commit splits it into several logical sections roughly based on function, recipes.txt gives more information about the classifications used. The opportunity is also used to switch from "packages" to "recipes" as used in OpenEmbedded as the term "packages" can be confusing to people and has many different meanings. Not all recipes have been classified yet, this is just a first pass at separating things out. Some packages are moved to meta-extras as they're no longer actively used or maintained. Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/recipes-kernel/modutils/modutils_2.4.27.bb')
-rw-r--r--meta/recipes-kernel/modutils/modutils_2.4.27.bb88
1 files changed, 88 insertions, 0 deletions
diff --git a/meta/recipes-kernel/modutils/modutils_2.4.27.bb b/meta/recipes-kernel/modutils/modutils_2.4.27.bb
new file mode 100644
index 0000000000..a5a9231322
--- /dev/null
+++ b/meta/recipes-kernel/modutils/modutils_2.4.27.bb
@@ -0,0 +1,88 @@
+SECTION = "base"
+DESCRIPTION = "These utilities are intended to make a Linux modular kernel \
+manageable for all users, administrators and distribution maintainers."
+LICENSE = "GPLv2"
+DEPENDS = "bison-native"
+PR = "r9"
+
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/utils/kernel/modutils/v2.4/modutils-${PV}.tar.bz2 \
+ file://lex.l.diff;patch=1 \
+ file://modutils-notest.patch;patch=1 \
+ file://configure.patch;patch=1 \
+ file://program_prefix.patch;patch=1 \
+ file://armeb.patch;patch=1 \
+ file://gcc4.patch;patch=1"
+
+inherit autotools
+
+# modutils go in /sbin
+sbindir = "/sbin"
+EXTRA_OECONF = "--disable-strip"
+export BUILDCC = "${BUILD_CC}"
+export BUILDCFLAGS = "${BUILD_CFLAGS}"
+
+do_install () {
+ oe_runmake 'DESTDIR=${D}' install
+ install -d ${D}${sysconfdir}
+ rm ${D}${base_sbindir}/lsmod
+ install -d ${D}${base_bindir}/
+ ln -s ../sbin/insmod ${D}${base_bindir}/lsmod
+ for f in bin/lsmod sbin/insmod sbin/rmmod sbin/modprobe sbin/modinfo sbin/depmod; do mv ${D}/$f ${D}/$f.24
+ done
+}
+
+pkg_postinst_modutils () {
+#!/bin/sh
+for f in sbin/insmod sbin/modprobe sbin/rmmod bin/lsmod; do
+ bn=`basename $f`
+ update-alternatives --install /$f $bn /$f.24 10
+done
+if test -n "$D"; then
+ D="-r $D"
+ if test -n "`which ${TARGET_PREFIX}depmod-2.4`"; then
+ for kerneldir in `ls -p $D/lib/modules|grep /`; do
+ kernelver=`basename $kerneldir`
+ ${TARGET_PREFIX}depmod-2.4 -a -b $D -C ${IMAGE_ROOTFS}/${sysconfdir}/modules.conf -r $kernelver
+ done
+ fi
+fi
+update-rc.d $D modutils.sh start 20 S .
+}
+
+pkg_prerm_modutils () {
+#!/bin/sh
+for f in sbin/insmod sbin/modprobe sbin/rmmod sbin/depmod sbin/modinfo bin/lsmod; do
+bn=`basename $f`
+ update-alternatives --remove $bn /$f.24
+done
+if test -n "$D"; then
+ D="-r $D"
+fi
+update-rc.d $D modutils.sh remove
+}
+
+pkg_postinst_modutils-depmod() {
+#!/bin/sh
+update-alternatives --install /sbin/depmod depmod /sbin/depmod.24 10
+}
+
+pkg_postinst_modutils-modinfo() {
+#!/bin/sh
+update-alternatives --install /sbin/modinfo modinfo /sbin/modinfo.24 10
+}
+
+pkg_prerm_modutils-depmod() {
+#!/bin/sh
+update-alternatives --remove depmod /sbin/depmod.24
+}
+
+pkg_prerm_modutils-modinfo() {
+#!/bin/sh
+update-alternatives --remove modinfo /sbin/modinfo.24
+}
+
+PACKAGES = "modutils-depmod modutils-modinfo modutils-doc modutils"
+
+FILES_modutils-depmod = "sbin/depmod.24"
+FILES_modutils-modinfo = "sbin/modinfo.24"
+RDEPENDS_modutils = "modutils-depmod"