aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/lttng/lttng-modules_2.10.4.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2018-01-16 11:16:16 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-03-26 15:06:26 +0100
commit173f3534a7217074f7291d42b1d572242bc710e0 (patch)
treeda0f5f3044163f666862a1a9b31719832df5dd75 /meta/recipes-kernel/lttng/lttng-modules_2.10.4.bb
parent22d30ed7c847b6ee4fdccb96fa9a3ce3d1491967 (diff)
downloadopenembedded-core-173f3534a7217074f7291d42b1d572242bc710e0.tar.gz
lttng-modules: upgrade 2.9.5 -> 2.10.4
LICENSE file contains a list of files and addtional files were added to the list, license was unchanged. (From OE-Core rev: f6372633b481fc267c1983a5276616513ec778a9) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta/recipes-kernel/lttng/lttng-modules_2.10.4.bb')
-rw-r--r--meta/recipes-kernel/lttng/lttng-modules_2.10.4.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta/recipes-kernel/lttng/lttng-modules_2.10.4.bb b/meta/recipes-kernel/lttng/lttng-modules_2.10.4.bb
new file mode 100644
index 0000000000..dd695f835d
--- /dev/null
+++ b/meta/recipes-kernel/lttng/lttng-modules_2.10.4.bb
@@ -0,0 +1,35 @@
+SECTION = "devel"
+SUMMARY = "Linux Trace Toolkit KERNEL MODULE"
+DESCRIPTION = "The lttng-modules 2.0 package contains the kernel tracer modules"
+LICENSE = "LGPLv2.1 & GPLv2 & MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=c4613d1f8a9587bd7b366191830364b3 \
+ file://gpl-2.0.txt;md5=751419260aa954499f7abaabaa882bbe \
+ file://lgpl-2.1.txt;md5=243b725d71bb5df4a1e5920b344b86ad \
+ "
+
+inherit module
+
+COMPATIBLE_HOST = '(x86_64|i.86|powerpc|aarch64|mips|nios2|arm).*-linux'
+
+SRC_URI = "https://lttng.org/files/${BPN}/${BPN}-${PV}.tar.bz2 \
+ file://Makefile-Do-not-fail-if-CONFIG_TRACEPOINTS-is-not-en.patch \
+ file://BUILD_RUNTIME_BUG_ON-vs-gcc7.patch \
+"
+
+SRC_URI[md5sum] = "832452b321a4df6836549e72d05b2ce9"
+SRC_URI[sha256sum] = "f918e3b890f378f47a9ba8710ff52590e9b1d9c63b12a0e64d138e2e2e1b3c8a"
+
+export INSTALL_MOD_DIR="kernel/lttng-modules"
+
+EXTRA_OEMAKE += "KERNELDIR='${STAGING_KERNEL_DIR}'"
+
+do_install_append() {
+ # Delete empty directories to avoid QA failures if no modules were built
+ find ${D}/${nonarch_base_libdir} -depth -type d -empty -exec rmdir {} \;
+}
+
+python do_package_prepend() {
+ if not os.path.exists(os.path.join(d.getVar('D'), d.getVar('nonarch_base_libdir')[1:], 'modules')):
+ bb.warn("%s: no modules were created; this may be due to CONFIG_TRACEPOINTS not being enabled in your kernel." % d.getVar('PN'))
+}
+