aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2010-10-17 01:14:11 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2010-10-18 01:17:46 -0400
commit1dc2a4c17ba261c3ffaf1820a5543a6a55b10335 (patch)
treec438ce5487a5e55bf1511fbcaff5f6f4244dca16 /meta/recipes-kernel/linux
parent77176d56fdd4158b34769fecca764a5b9c87e04b (diff)
downloadopenembedded-core-1dc2a4c17ba261c3ffaf1820a5543a6a55b10335.tar.gz
linux-wrs: allow optional features via KERNEL_FEATURES variable
Fixes [BUGID #199] Reinstate the ability to specify optional/additional kernel features when updating the tree. This is done via the variable KERNEL_FEATURES which specifies a list of features to be appended to the current branch and config. These features are part of the wrs_meta branch in the kernel repository and hence are self contained within the kernel tree waiting to be activated. This saves multiple branches simply to allow a machine to have many profiles. The kernel patching/configuration phases will locate these features and add them to the meta_series, which in turn modifies the tree. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta/recipes-kernel/linux')
-rw-r--r--meta/recipes-kernel/linux/linux-wrs_git.bb7
1 files changed, 5 insertions, 2 deletions
diff --git a/meta/recipes-kernel/linux/linux-wrs_git.bb b/meta/recipes-kernel/linux/linux-wrs_git.bb
index 2459b79c89..763eaf1559 100644
--- a/meta/recipes-kernel/linux/linux-wrs_git.bb
+++ b/meta/recipes-kernel/linux/linux-wrs_git.bb
@@ -49,8 +49,11 @@ do_patch() {
exit 1
fi
- # updates or generates the target description
- updateme ${ARCH} ${WORKDIR}
+ # updates or generates the target description
+ if [ -n "${KERNEL_FEATURES}" ]; then
+ addon_features="--features ${KERNEL_FEATURES}"
+ fi
+ updateme ${addon_features} ${ARCH} ${WORKDIR}
if [ $? -ne 0 ]; then
echo "ERROR. Could not update ${WRMACHINE}-${LINUX_KERNEL_TYPE}"
exit 1