summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto_2.6.37.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2011-06-08 15:33:02 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-06-14 13:15:52 +0100
commit576c87349a72a94357014ff29f55db692903ed80 (patch)
tree9f75e3216dbd8a45d460bbecfed129bd043530cf /meta/recipes-kernel/linux/linux-yocto_2.6.37.bb
parent6625936c011aa939e60041dc6be9850e925a6cc3 (diff)
downloadopenembedded-core-576c87349a72a94357014ff29f55db692903ed80.tar.gz
linux-yocto: rename recipes to explicitly indicate version
The existing recipe names for the linux-yocto kernel builds worked well when there was a single, or two versions of the kernel available. But with the impending kernel updates and retirement of older kernels, the re-use of the same recipes for different kernel versions violates the principle of least surprise. To address this, the recipes are being renamed as follows: linux-yocto_git.bb -> linux-yocto_2.6.37.bb linux-yocto-stable_git.bb -> linux-yocto_2.6.34.bb There continue to be versionless recipe names that feed into versioned recipes at the appropriate points. They are: linux-yocto-dev.bb (tracking the latest yocto dev kernel) linux-yocto-korg_head.bb (tracking korg kernels) There are no existing users of linux-yocto-stable in the master branches to convert to the new naming, so these changes work in isolation. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto_2.6.37.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_2.6.37.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto_2.6.37.bb b/meta/recipes-kernel/linux/linux-yocto_2.6.37.bb
new file mode 100644
index 0000000000..1d43e1e381
--- /dev/null
+++ b/meta/recipes-kernel/linux/linux-yocto_2.6.37.bb
@@ -0,0 +1,46 @@
+inherit kernel
+require linux-yocto.inc
+
+KMACHINE = "yocto/standard/base"
+KMACHINE_qemux86 = "yocto/standard/common-pc/base"
+KMACHINE_qemux86-64 = "yocto/standard/common-pc-64/base"
+KMACHINE_qemuppc = "yocto/standard/qemu-ppc32"
+KMACHINE_qemumips = "yocto/standard/mti-malta32-be"
+KMACHINE_qemuarm = "yocto/standard/arm-versatile-926ejs"
+
+KBRANCH = ${KMACHINE}
+KMETA = meta
+
+LINUX_VERSION ?= "2.6.37"
+LINUX_VERSION_EXTENSION ?= "-yocto-${LINUX_KERNEL_TYPE}"
+
+SRCREV_machine_qemuarm = "2070a54dbde57d2987c832a016b05949f7e6e086"
+SRCREV_machine_qemumips = "bd9eab8e382e11dc08a5de8b010570f03de949e5"
+SRCREV_machine_qemuppc = "704497b3a48c0882078f6167277d65d932292535"
+SRCREV_machine_qemux86 = "c1a74a7872fdd1152265087aa7e59b96a8f2f42a"
+SRCREV_machine_qemux86-64 = "1950ea205407d8950475a37404173572d55fd27f"
+SRCREV_machine = "697d84759be192403a8a87ab269196c67a0c2c88"
+SRCREV_meta = "f1dc3722d45cdcc92c84ebfecf4ce616d2efed26"
+
+PR = "r18"
+PV = "${LINUX_VERSION}+git${SRCPV}"
+SRCREV_FORMAT = "meta_machine"
+
+SRC_URI = "git://git.yoctoproject.org/linux-yocto-2.6.37;protocol=git;nocheckout=1;branch=${KBRANCH},meta;name=machine,meta"
+
+COMPATIBLE_MACHINE = "(qemuarm|qemux86|qemuppc|qemumips|qemux86-64)"
+
+# Functionality flags
+KERNEL_REVISION_CHECKING ?= "t"
+KERNEL_FEATURES="features/netfilter"
+KERNEL_FEATURES_append_qemux86=" cfg/sound"
+KERNEL_FEATURES_append_qemux86-64=" cfg/sound"
+
+YOCTO_KERNEL_META_DATA=t
+
+# extra tasks
+addtask kernel_link_vmlinux after do_compile before do_install
+addtask validate_branches before do_patch after do_kernel_checkout
+addtask kernel_configcheck after do_configure before do_compile
+
+require linux-tools.inc