summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2012-07-16 10:25:49 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-07-17 10:28:41 +0100
commitabdc37d181019b9dd21ad08ad998ea4ff2a3e264 (patch)
treeca2fe3bb80061772e46014fda20b9ca11cb3a820 /meta/recipes-graphics
parent077bd603040ebd16f01b4fa20999fb71a9a43695 (diff)
downloadopenembedded-core-abdc37d181019b9dd21ad08ad998ea4ff2a3e264.tar.gz
libx11: fix makekeys build
* on hosts without libx11 installed it fails with | makekeys.c:33:27: fatal error: X11/Xresource.h: No such file or directory since oe-core rev 52d4ff7b35602faa52360a3e7a800891ef60c739 * upstream added -I$(top_srcdir)/include in 24283d40b1e4314c6647dda49d2a159833341a8b to ensure that right Xresource.h version is used, but we're building makekeys outside source tree (x11_disable_makekeys.patch), so we need to pass -I${S}/include in our makekeys build too * building makekeys outside source tree isn't probably needed anymore and recipes should be updated to reflect that, upstream fixes: https://bugs.freedesktop.org/show_bug.cgi?id=22584 http://cgit.freedesktop.org/xorg/lib/libX11/commit/src/util/Makefile.am?id=b2487d07f7b355f230a56e32c763acd08862735c http://cgit.freedesktop.org/xorg/lib/libX11/commit/src/util/Makefile.am?id=24283d40b1e4314c6647dda49d2a159833341a8b Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics')
-rw-r--r--meta/recipes-graphics/xorg-lib/libx11-diet_1.5.0.bb2
-rw-r--r--meta/recipes-graphics/xorg-lib/libx11-trim_1.5.0.bb2
-rw-r--r--meta/recipes-graphics/xorg-lib/libx11.inc4
-rw-r--r--meta/recipes-graphics/xorg-lib/libx11_1.5.0.bb2
4 files changed, 5 insertions, 5 deletions
diff --git a/meta/recipes-graphics/xorg-lib/libx11-diet_1.5.0.bb b/meta/recipes-graphics/xorg-lib/libx11-diet_1.5.0.bb
index 4ae8b29a7f..7d4facdb05 100644
--- a/meta/recipes-graphics/xorg-lib/libx11-diet_1.5.0.bb
+++ b/meta/recipes-graphics/xorg-lib/libx11-diet_1.5.0.bb
@@ -5,7 +5,7 @@ this version."
LIC_FILES_CHKSUM = "file://COPYING;md5=172255dee66bb0151435b2d5d709fcf7"
-PR = "r0"
+PR = "r1"
SRC_URI += "file://x11_disable_makekeys.patch \
file://X18NCMSstubs.diff \
diff --git a/meta/recipes-graphics/xorg-lib/libx11-trim_1.5.0.bb b/meta/recipes-graphics/xorg-lib/libx11-trim_1.5.0.bb
index 89c45974f3..3d5a306a17 100644
--- a/meta/recipes-graphics/xorg-lib/libx11-trim_1.5.0.bb
+++ b/meta/recipes-graphics/xorg-lib/libx11-trim_1.5.0.bb
@@ -5,7 +5,7 @@ DESCRIPTION += " Support for XCMS is disabled in this version."
LICENSE = "MIT & MIT-style & BSD"
LIC_FILES_CHKSUM = "file://COPYING;md5=172255dee66bb0151435b2d5d709fcf7"
-PR = "r0"
+PR = "r1"
DEPENDS += "libxcb xproto xextproto xtrans libxau kbproto inputproto xf86bigfontproto xproto-native"
diff --git a/meta/recipes-graphics/xorg-lib/libx11.inc b/meta/recipes-graphics/xorg-lib/libx11.inc
index a1e4386feb..592f116532 100644
--- a/meta/recipes-graphics/xorg-lib/libx11.inc
+++ b/meta/recipes-graphics/xorg-lib/libx11.inc
@@ -35,9 +35,9 @@ do_compile_prepend() {
sed -i -e 's:MIN_REHASH 15:MIN_REHASH 16:g' makekeys.c
touch makekeys-makekeys.o;
if [ "${SITEINFO_BITS}" == "64" ]; then
- ${BUILD_CC} ${BUILD_CFLAGS} -I${STAGING_INCDIR_NATIVE} makekeys.c -o makekeys
+ ${BUILD_CC} ${BUILD_CFLAGS} -I${STAGING_INCDIR_NATIVE} makekeys.c -I${S}/include -o makekeys
else
- ${BUILD_CC} ${BUILD_CFLAGS} -I${STAGING_INCDIR_NATIVE} -DUSE32 makekeys.c -o makekeys
+ ${BUILD_CC} ${BUILD_CFLAGS} -I${STAGING_INCDIR_NATIVE} -DUSE32 makekeys.c -I${S}/include -o makekeys
fi
)
if [ "$?" != "0" ]; then
diff --git a/meta/recipes-graphics/xorg-lib/libx11_1.5.0.bb b/meta/recipes-graphics/xorg-lib/libx11_1.5.0.bb
index 04805d74f4..a65ab1faad 100644
--- a/meta/recipes-graphics/xorg-lib/libx11_1.5.0.bb
+++ b/meta/recipes-graphics/xorg-lib/libx11_1.5.0.bb
@@ -1,7 +1,7 @@
require libx11.inc
inherit gettext
-PR = "r0"
+PR = "r1"
BBCLASSEXTEND = "native nativesdk"