summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics
diff options
context:
space:
mode:
authorMaxin B. John <maxin.john@intel.com>2017-08-14 15:09:05 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-08-16 09:18:46 +0100
commitab7f6ba2bab04bdfaa76a1de83806dbadc82fefa (patch)
treee4c3fec64f40e2b0c895e0646b801652d56e06b7 /meta/recipes-graphics
parente1dda927d3734c0d272cfc7d99167498ca9d8f6d (diff)
downloadopenembedded-core-ab7f6ba2bab04bdfaa76a1de83806dbadc82fefa.tar.gz
libva-utils: add recipe
Utilities and tests in the libva was spun-off as libva-utils during 1.8.0 release. libva-utils is a collection of utilities and examples to exercise VA-API in accordance with the libva project Signed-off-by: Maxin B. John <maxin.john@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics')
-rw-r--r--meta/recipes-graphics/libva/libva-utils_1.8.3.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-graphics/libva/libva-utils_1.8.3.bb b/meta/recipes-graphics/libva/libva-utils_1.8.3.bb
new file mode 100644
index 0000000000..9c2c0d657b
--- /dev/null
+++ b/meta/recipes-graphics/libva/libva-utils_1.8.3.bb
@@ -0,0 +1,30 @@
+SUMMARY = "libva-utils is a collection of utilities from libva project"
+
+DESCRIPTION = "libva-utils is a collection of utilities \
+and examples to exercise VA-API in accordance with the libva \
+project.VA-API is an open-source library and API specification, \
+which provides access to graphics hardware acceleration capabilities \
+for video processing. It consists of a main library and driver-specific \
+acceleration backends for each supported hardware vendor"
+
+HOMEPAGE = "https://01.org/linuxmedia/vaapi"
+BUGTRACKER = "https://github.com/01org/libva-utils/issues"
+
+SECTION = "x11"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b148fc8adf19dc9aec17cf9cd29a9a5e"
+
+SRC_URI = "git://github.com/01org/libva-utils.git;branch=v1.8-branch"
+SRCREV = "011c709b98b52db3b10aeb361dfea9da43930364"
+UPSTREAM_CHECK_URI = "https://github.com/01org/libva-utils/releases"
+UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>(\d+(\.\d+)+))"
+
+S = "${WORKDIR}/git"
+
+DEPENDS = "libva"
+
+inherit autotools pkgconfig distro_features_check
+
+PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'wayland x11', d)}"
+PACKAGECONFIG[x11] = "--enable-x11,--disable-x11,virtual/libx11 libxext libxfixes"
+PACKAGECONFIG[wayland] = "--enable-wayland,--disable-wayland,wayland-native wayland"