summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2018-09-29 14:13:30 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-10-01 13:04:44 +0100
commit72c37b06b034e97e7dd7e1a20fb0ff5f96088440 (patch)
treebe103d8cff8fc40ea8dac99d9aae09a383c970e9 /meta/recipes-graphics
parent5a26b03c9f73822554ea969e42bca82217dfd3f8 (diff)
downloadopenembedded-core-72c37b06b034e97e7dd7e1a20fb0ff5f96088440.tar.gz
libsdl2: disable sndio explicitly to avoid inconsistent result
Explicitly disable sndio to avoid inconsistent result on different hosts having or not having libsndio. This must be done if we take into consideration of eSDK. I built eSDK on Ubuntu 14.04 which has libsndio installed, and then installed the eSDK on Fedora 27, which does not have libsndio. In fact, on Fedora 27, I even cannot find libsndio in its repo. The problem happens when trying to use `devtool runqemu'. The qemu binary built on Ubuntu 14.04 needs to link to libsndio, and thus the following error. runqemu - ERROR - Failed to run qemu: /path/to/qemu-system-x86_64: error while loading shared libraries: libsndio.so.6.1: cannot open shared object file: No such file or directory So explicitly disable sndio for libsdl2 to avoid the above problem. Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics')
-rw-r--r--meta/recipes-graphics/libsdl2/libsdl2_2.0.8.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-graphics/libsdl2/libsdl2_2.0.8.bb b/meta/recipes-graphics/libsdl2/libsdl2_2.0.8.bb
index 52bb93a17a..812a9abf3c 100644
--- a/meta/recipes-graphics/libsdl2/libsdl2_2.0.8.bb
+++ b/meta/recipes-graphics/libsdl2/libsdl2_2.0.8.bb
@@ -30,6 +30,7 @@ EXTRA_OECONF = "--disable-oss --disable-esd --disable-arts \
--enable-pthreads \
--enable-sdl-dlopen \
--disable-rpath \
+ --disable-sndio \
"
# opengl packageconfig factored out to make it easy for distros