summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics
diff options
context:
space:
mode:
authorJussi Kukkonen <jussi.kukkonen@intel.com>2017-07-12 15:11:43 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-07-17 13:49:00 +0100
commit6a079bf5a446c2e98e7444e04dfadaff96342b4f (patch)
treee3eea9fbbc301f8e6f0bffa60ef8fce9dfa2ac86 /meta/recipes-graphics
parentf759420ad2a60d0be4ca15f4c9294086ecc86e59 (diff)
downloadopenembedded-core-6a079bf5a446c2e98e7444e04dfadaff96342b4f.tar.gz
mesa: Avoid installing khrplatfrom.h when not needed
Fix the conflict between mesa and userland (when former is used to provide GL and letter used to provide EGL+GLES) by not installing khrplatform.h header when its not needed. Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-graphics')
-rw-r--r--meta/recipes-graphics/mesa/files/0001-mapi-Only-install-khrplatform.h-with-EGL-or-GLES.patch52
-rw-r--r--meta/recipes-graphics/mesa/mesa_17.1.4.bb1
2 files changed, 53 insertions, 0 deletions
diff --git a/meta/recipes-graphics/mesa/files/0001-mapi-Only-install-khrplatform.h-with-EGL-or-GLES.patch b/meta/recipes-graphics/mesa/files/0001-mapi-Only-install-khrplatform.h-with-EGL-or-GLES.patch
new file mode 100644
index 0000000000..be61e2edfe
--- /dev/null
+++ b/meta/recipes-graphics/mesa/files/0001-mapi-Only-install-khrplatform.h-with-EGL-or-GLES.patch
@@ -0,0 +1,52 @@
+From 922cb47a5b950ee5545a7a3cb4cd9a88a8b15054 Mon Sep 17 00:00:00 2001
+From: Jussi Kukkonen <jussi.kukkonen@intel.com>
+Date: Wed, 12 Jul 2017 12:21:29 +0300
+Subject: [PATCH] mapi: Only install khrplatform.h with EGL or GLES
+
+When mesa is built with "--disable-egl --disable-gles1
+--disable-gles2" the KHR platform headers are not needed.
+
+Not installing the header when not needed allows using mesa for GL
+and another implementation for GLES+EGL (as is done in practice with
+userland on raspberrypi).
+
+Upstream-Status: Pending [waiting for test results before sending]
+Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com>
+---
+ src/mapi/Makefile.am | 9 ++++++++-
+ 1 file changed, 8 insertions(+), 1 deletion(-)
+
+diff --git a/src/mapi/Makefile.am b/src/mapi/Makefile.am
+index 9ff70a14fd..94c77fb82c 100644
+--- a/src/mapi/Makefile.am
++++ b/src/mapi/Makefile.am
+@@ -188,6 +188,8 @@ es1api_libGLESv1_CM_la_LDFLAGS = \
+ $(LD_NO_UNDEFINED)
+
+ es1api_libGLESv1_CM_la_LIBADD += shared-glapi/libglapi.la
++
++khr_HEADERS = $(top_srcdir)/include/KHR/khrplatform.h
+ endif
+
+ es1api/glapi_mapi_tmp.h: glapi/gen/gl_and_es_API.xml $(glapi_gen_mapi_deps)
+@@ -233,6 +235,12 @@ es2api_libGLESv2_la_LDFLAGS = \
+ $(LD_NO_UNDEFINED)
+
+ es2api_libGLESv2_la_LIBADD += shared-glapi/libglapi.la
++
++khr_HEADERS = $(top_srcdir)/include/KHR/khrplatform.h
++endif
++
++if HAVE_EGL
++khr_HEADERS = $(top_srcdir)/include/KHR/khrplatform.h
+ endif
+
+ es2api/glapi_mapi_tmp.h: glapi/gen/gl_and_es_API.xml $(glapi_gen_mapi_deps)
+@@ -243,4 +251,3 @@ es2api/glapi_mapi_tmp.h: glapi/gen/gl_and_es_API.xml $(glapi_gen_mapi_deps)
+ include $(top_srcdir)/install-lib-links.mk
+
+ khrdir = $(includedir)/KHR
+-khr_HEADERS = $(top_srcdir)/include/KHR/khrplatform.h
+--
+2.13.2
+
diff --git a/meta/recipes-graphics/mesa/mesa_17.1.4.bb b/meta/recipes-graphics/mesa/mesa_17.1.4.bb
index 3289cd63a9..2257045c42 100644
--- a/meta/recipes-graphics/mesa/mesa_17.1.4.bb
+++ b/meta/recipes-graphics/mesa/mesa_17.1.4.bb
@@ -6,6 +6,7 @@ SRC_URI = "https://mesa.freedesktop.org/archive/mesa-${PV}.tar.xz \
file://etnaviv_fix-shader-miscompilation.patch \
file://0001-Use-wayland-scanner-in-the-path.patch \
file://0002-hardware-gloat.patch \
+ file://0001-mapi-Only-install-khrplatform.h-with-EGL-or-GLES.patch \
"
SRC_URI[md5sum] = "be2ef7c9edec23b07f74f6512a6a6fa5"