summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2017-11-15 16:44:14 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-03-07 06:33:59 -0800
commit453a433768bff76e4d3ad9bf40fd9d8210b0950e (patch)
treeee3d64f9363e241b887f11576a3d51dd71884611 /meta/recipes-graphics
parenta9f9ca73840d1e6911e496a32ee862a724615b50 (diff)
downloadopenembedded-core-453a433768bff76e4d3ad9bf40fd9d8210b0950e.tar.gz
vulkan: refresh patches
The patch tool will apply patches by default with "fuzz", which is where if the hunk context isn't present but what is there is close enough, it will force the patch in. Whilst this is useful when there's just whitespace changes, when applied to source it is possible for a patch applied with fuzz to produce broken code which still compiles (see #10450). This is obviously bad. We'd like to eventually have do_patch() rejecting any fuzz on these grounds. For that to be realistic the existing patches with fuzz need to be rebased and reviewed. Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-graphics')
-rw-r--r--meta/recipes-graphics/vulkan/vulkan/demos-Don-t-build-tri-or-cube.patch12
1 files changed, 7 insertions, 5 deletions
diff --git a/meta/recipes-graphics/vulkan/vulkan/demos-Don-t-build-tri-or-cube.patch b/meta/recipes-graphics/vulkan/vulkan/demos-Don-t-build-tri-or-cube.patch
index 3cf241d62a..bcf84a5a3e 100644
--- a/meta/recipes-graphics/vulkan/vulkan/demos-Don-t-build-tri-or-cube.patch
+++ b/meta/recipes-graphics/vulkan/vulkan/demos-Don-t-build-tri-or-cube.patch
@@ -11,9 +11,11 @@ Date: Tue Feb 16 10:05:25 2016 -0500
Upstream-Status: Inappropriate [configuration]
Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com>
---- a/demos/CMakeLists.txt
-+++ b/demos/CMakeLists.txt
-@@ -61,46 +61,6 @@
+Index: git/demos/CMakeLists.txt
+===================================================================
+--- git.orig/demos/CMakeLists.txt
++++ git/demos/CMakeLists.txt
+@@ -63,46 +63,6 @@ elseif(UNIX)
else()
endif()
@@ -60,7 +62,7 @@ Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com>
if(WIN32)
include_directories (
-@@ -114,43 +74,6 @@
+@@ -116,43 +76,6 @@ endif()
add_executable(${API_LOWERCASE}info vulkaninfo.c)
target_link_libraries(${API_LOWERCASE}info ${LIBRARIES})
@@ -103,4 +105,4 @@ Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com>
-endif()
if(UNIX)
- install(TARGETS ${API_LOWERCASE}info DESTINATION ${CMAKE_INSTALL_BINDIR})
+ if(INSTALL_LVL_FILES)