summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2018-03-08 20:17:38 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-03-09 09:16:01 -0800
commit320f03b8492e5259c45e7c59b62571d5a827ee59 (patch)
tree4db479319cb665f812b20a5ee2b3b223757a648a /meta/recipes-graphics
parentc6ec48b718ae674a5b362a3dbfe02420a569ad30 (diff)
downloadopenembedded-core-320f03b8492e5259c45e7c59b62571d5a827ee59.tar.gz
wayland: refresh patches
The patch tool will apply patches by default with "fuzz", which is where if the hunk context isn't present but what is there is close enough, it will force the patch in. Whilst this is useful when there's just whitespace changes, when applied to source it is possible for a patch applied with fuzz to produce broken code which still compiles (see #10450). This is obviously bad. We'd like to eventually have do_patch() rejecting any fuzz on these grounds. For that to be realistic the existing patches with fuzz need to be rebased and reviewed. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-graphics')
-rw-r--r--meta/recipes-graphics/wayland/wayland/fixpathinpcfiles.patch3
-rw-r--r--meta/recipes-graphics/wayland/weston/0001-make-error-portable.patch22
2 files changed, 15 insertions, 10 deletions
diff --git a/meta/recipes-graphics/wayland/wayland/fixpathinpcfiles.patch b/meta/recipes-graphics/wayland/wayland/fixpathinpcfiles.patch
index 9fb1252284..ad3526d984 100644
--- a/meta/recipes-graphics/wayland/wayland/fixpathinpcfiles.patch
+++ b/meta/recipes-graphics/wayland/wayland/fixpathinpcfiles.patch
@@ -21,8 +21,7 @@ Index: wayland-1.14.0/src/wayland-scanner.pc.in
===================================================================
--- wayland-1.14.0.orig/src/wayland-scanner.pc.in
+++ wayland-1.14.0/src/wayland-scanner.pc.in
-@@ -1,8 +1,8 @@
- prefix=@prefix@
+@@ -2,7 +2,7 @@ prefix=@prefix@
exec_prefix=@exec_prefix@
datarootdir=@datarootdir@
pkgdatadir=@datadir@/@PACKAGE@
diff --git a/meta/recipes-graphics/wayland/weston/0001-make-error-portable.patch b/meta/recipes-graphics/wayland/weston/0001-make-error-portable.patch
index e2213aca60..0671a45044 100644
--- a/meta/recipes-graphics/wayland/weston/0001-make-error-portable.patch
+++ b/meta/recipes-graphics/wayland/weston/0001-make-error-portable.patch
@@ -16,9 +16,11 @@ Upstream-Status: Submitted
3 files changed, 23 insertions(+), 1 deletion(-)
create mode 100644 src/weston-error.h
---- a/configure.ac
-+++ b/configure.ac
-@@ -60,6 +60,8 @@ AC_CHECK_DECL(CLOCK_MONOTONIC,[],
+Index: weston-3.0.0/configure.ac
+===================================================================
+--- weston-3.0.0.orig/configure.ac
++++ weston-3.0.0/configure.ac
+@@ -103,6 +103,8 @@ AC_CHECK_DECL(CLOCK_MONOTONIC,[],
[[#include <time.h>]])
AC_CHECK_HEADERS([execinfo.h])
@@ -26,9 +28,11 @@ Upstream-Status: Submitted
+
AC_CHECK_FUNCS([mkostemp strchrnul initgroups posix_fallocate])
- COMPOSITOR_MODULES="wayland-server >= $WAYLAND_PREREQ_VERSION pixman-1 >= 0.25.2"
+ # check for libdrm as a build-time dependency only
+Index: weston-3.0.0/libweston/weston-error.h
+===================================================================
--- /dev/null
-+++ b/libweston/weston-error.h
++++ weston-3.0.0/libweston/weston-error.h
@@ -0,0 +1,20 @@
+#ifndef _WESTON_ERROR_H
+#define _WESTON_ERROR_H
@@ -50,8 +54,10 @@ Upstream-Status: Submitted
+
+#endif
+
---- a/libweston/weston-launch.c
-+++ b/libweston/weston-launch.c
+Index: weston-3.0.0/libweston/weston-launch.c
+===================================================================
+--- weston-3.0.0.orig/libweston/weston-launch.c
++++ weston-3.0.0/libweston/weston-launch.c
@@ -33,7 +33,6 @@
#include <poll.h>
#include <errno.h>
@@ -60,7 +66,7 @@ Upstream-Status: Submitted
#include <getopt.h>
#include <sys/types.h>
-@@ -59,6 +58,7 @@
+@@ -60,6 +59,7 @@
#endif
#include "weston-launch.h"