summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2018-02-04 20:27:59 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-02-09 14:31:59 +0000
commit230890227304e27acd074a3c748812d7a603d511 (patch)
tree1632af88c78cc6eb8cf2cfa96eb36da9d6627bc1 /meta/recipes-graphics
parent8bbb43e948af45d0fa5ab31b456147f691fa2ec3 (diff)
downloadopenembedded-core-230890227304e27acd074a3c748812d7a603d511.tar.gz
python-xcbgen: improve reproducibility
Use relative path to generate .pyc files could remove build host references which leads to non-reproducible builds. Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-graphics')
-rw-r--r--meta/recipes-graphics/xorg-proto/xcb-proto_1.12.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-graphics/xorg-proto/xcb-proto_1.12.bb b/meta/recipes-graphics/xorg-proto/xcb-proto_1.12.bb
index bc04bc48ea..be6b1a0200 100644
--- a/meta/recipes-graphics/xorg-proto/xcb-proto_1.12.bb
+++ b/meta/recipes-graphics/xorg-proto/xcb-proto_1.12.bb
@@ -36,5 +36,5 @@ do_install_append() {
# Makefile's do_install creates .pyc files for python3, now also create
# them for python2 so that they will be recorded by manifest, and can be
# cleaned correctly.
- python -m py_compile ${D}${libdir}/xcb-proto/xcbgen/*.py
+ (cd ${D}; python -m py_compile ./${libdir}/xcb-proto/xcbgen/*.py)
}