summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2017-07-12 17:18:30 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-07-17 13:49:00 +0100
commit19e793f65d214294baa9eeaf982f4ced351c7748 (patch)
tree08178ae277c82febfb49fee51689ca7086a6eb8e /meta/recipes-graphics
parentfa3e2b4c07dffd14b02741470ce274619e9a9bd6 (diff)
downloadopenembedded-core-19e793f65d214294baa9eeaf982f4ced351c7748.tar.gz
mesa: fix build race on src/intel/vulkan
It's possible that src/intel/vulkcan can be written into by sed before it has been created, so add the required mkdir calls. Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-graphics')
-rw-r--r--meta/recipes-graphics/mesa/files/vulkan-mkdir.patch37
-rw-r--r--meta/recipes-graphics/mesa/mesa_17.1.4.bb1
2 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-graphics/mesa/files/vulkan-mkdir.patch b/meta/recipes-graphics/mesa/files/vulkan-mkdir.patch
new file mode 100644
index 0000000000..15ee5eeb14
--- /dev/null
+++ b/meta/recipes-graphics/mesa/files/vulkan-mkdir.patch
@@ -0,0 +1,37 @@
+Upstream-Status: Submitted
+Signed-off-by: Ross Burton <ross.burton@intel.com>
+
+From c78979fd95a1c4f732f7e6edf0f32c524e5955b8 Mon Sep 17 00:00:00 2001
+From: Ross Burton <ross.burton@intel.com>
+Date: Wed, 12 Jul 2017 17:10:07 +0100
+Subject: [PATCH] src/intel/Makefile.vulkan.am: create target directories when
+ required
+
+In out-of-tree builds src/intel/vulkan won't exist, so always create it before
+writing into it.
+
+Signed-off-by: Ross Burton <ross.burton@intel.com>
+---
+ src/intel/Makefile.vulkan.am | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/src/intel/Makefile.vulkan.am b/src/intel/Makefile.vulkan.am
+index 3857a5dc62..26e9cd410c 100644
+--- a/src/intel/Makefile.vulkan.am
++++ b/src/intel/Makefile.vulkan.am
+@@ -44,11 +44,13 @@ EXTRA_DIST += \
+ vulkan/TODO
+
+ vulkan/dev_icd.json : vulkan/dev_icd.json.in
++ $(MKDIR_GEN)
+ $(AM_V_GEN) $(SED) \
+ -e "s#@build_libdir@#${abs_top_builddir}/${LIB_DIR}#" \
+ < $(srcdir)/vulkan/dev_icd.json.in > $@
+
+ vulkan/intel_icd.@host_cpu@.json : vulkan/intel_icd.json.in
++ $(MKDIR_GEN)
+ $(AM_V_GEN) $(SED) \
+ -e "s#@install_libdir@#${libdir}#" \
+ < $(srcdir)/vulkan/intel_icd.json.in > $@
+--
+2.11.0
diff --git a/meta/recipes-graphics/mesa/mesa_17.1.4.bb b/meta/recipes-graphics/mesa/mesa_17.1.4.bb
index 2257045c42..f0b634a045 100644
--- a/meta/recipes-graphics/mesa/mesa_17.1.4.bb
+++ b/meta/recipes-graphics/mesa/mesa_17.1.4.bb
@@ -7,6 +7,7 @@ SRC_URI = "https://mesa.freedesktop.org/archive/mesa-${PV}.tar.xz \
file://0001-Use-wayland-scanner-in-the-path.patch \
file://0002-hardware-gloat.patch \
file://0001-mapi-Only-install-khrplatform.h-with-EGL-or-GLES.patch \
+ file://vulkan-mkdir.patch \
"
SRC_URI[md5sum] = "be2ef7c9edec23b07f74f6512a6a6fa5"