aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2016-02-23 16:32:07 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-02-28 11:32:36 +0000
commit8cc47e6bfb7f623711d9cd9e71a7f72ab2838f57 (patch)
tree75e99cc62968050625de6e6d92dc0c532b4f132b /meta/recipes-graphics
parentf70ee77add3878b4e43f5e79e159e44b4bea725b (diff)
downloadopenembedded-core-8cc47e6bfb7f623711d9cd9e71a7f72ab2838f57.tar.gz
fontconfig: Don't add font directories from host
* when enabled, configure check for "fonts" directory existence in following directories: /usr/X11R6/lib/X11 /usr/X11/lib/X11 /usr/lib/X11 on _host_ system and if it exists it adds <dir> element to /etc/fonts/fonts.conf * update_font_cache postinst will then fail if host system has e.g. /usr/lib/X11/fonts while the rootfs doesn't have it * if you're installing fonts to other directories, you'll need to adapt this EXTRA_OECONF to find them that's why it's in separate variable [YOCTO #9155] - update_font_cache postinst failing with read-only filesystem Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-graphics')
-rw-r--r--meta/recipes-graphics/fontconfig/fontconfig_2.11.94.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta/recipes-graphics/fontconfig/fontconfig_2.11.94.bb b/meta/recipes-graphics/fontconfig/fontconfig_2.11.94.bb
index 9bbff208c4..b3bc7ebf4a 100644
--- a/meta/recipes-graphics/fontconfig/fontconfig_2.11.94.bb
+++ b/meta/recipes-graphics/fontconfig/fontconfig_2.11.94.bb
@@ -40,6 +40,10 @@ inherit autotools pkgconfig
FONTCONFIG_CACHE_DIR ?= "${localstatedir}/cache/fontconfig"
-EXTRA_OECONF = " --disable-docs --with-default-fonts=${datadir}/fonts --with-cache-dir=${FONTCONFIG_CACHE_DIR}"
+# comma separated list of additional directories
+# /usr/share/fonts is already included by default (you can change it with --with-default-fonts)
+FONTCONFIG_FONT_DIRS ?= "no"
+
+EXTRA_OECONF = " --disable-docs --with-default-fonts=${datadir}/fonts --with-cache-dir=${FONTCONFIG_CACHE_DIR} --with-add-fonts=${FONTCONFIG_FONT_DIRS}"
BBCLASSEXTEND = "native"