aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2016-04-26 19:20:30 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-06-29 19:33:25 +0100
commit6eb173a6f4e67a9426dd19307a65dde6f3bf8974 (patch)
tree19fc9516d7628aa5d6baf641ce984d8ea0a2d8a0 /meta/recipes-graphics
parentb4db000519da45cc4e911a43dedaa5bd20a8624e (diff)
downloadopenembedded-core-6eb173a6f4e67a9426dd19307a65dde6f3bf8974.tar.gz
libxsettings-client: fix COPYING file
Fixed: * Move the code of copy COPYING file from do_configure_append() to do_patch[postfuncs] since we had moved license-checksum from do_package_qa to do_populate_lic. * Add xsettings-client.c and xsettings-common.c to LIC_FILES_CHKSUM. * Update comments. (From OE-Core rev: 89332686ac6c756672cbf67c2df70c5150efa998) Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Armin Kuster <akuster@mvista.com>
Diffstat (limited to 'meta/recipes-graphics')
-rw-r--r--meta/recipes-graphics/libxsettings-client/libxsettings-client_0.10.bb13
1 files changed, 8 insertions, 5 deletions
diff --git a/meta/recipes-graphics/libxsettings-client/libxsettings-client_0.10.bb b/meta/recipes-graphics/libxsettings-client/libxsettings-client_0.10.bb
index 67c5e27776..9e9336e5db 100644
--- a/meta/recipes-graphics/libxsettings-client/libxsettings-client_0.10.bb
+++ b/meta/recipes-graphics/libxsettings-client/libxsettings-client_0.10.bb
@@ -9,7 +9,9 @@ SECTION = "x/libs"
LICENSE = "MIT-style"
LIC_FILES_CHKSUM = "file://COPYING;md5=7cfac9d2d4dc3694cc7eb605cf32a69b \
file://xsettings-client.h;endline=22;md5=7cfac9d2d4dc3694cc7eb605cf32a69b \
- file://xsettings-common.h;endline=22;md5=7cfac9d2d4dc3694cc7eb605cf32a69b"
+ file://xsettings-client.c;endline=22;md5=7cfac9d2d4dc3694cc7eb605cf32a69b \
+ file://xsettings-common.h;endline=22;md5=7cfac9d2d4dc3694cc7eb605cf32a69b \
+ file://xsettings-common.c;endline=22;md5=7cfac9d2d4dc3694cc7eb605cf32a69b"
DEPENDS = "virtual/libx11"
PR = "r5"
@@ -31,10 +33,11 @@ inherit autotools gettext distro_features_check
# depends on virtual/libx11
REQUIRED_DISTRO_FEATURES = "x11"
-do_configure_prepend() {
- # This package doesn't ship with its own COPYING file and
- # autotools will install a GPLv2 one instead of the actual MIT-style license here.
- # Add the correct license here to avoid confusion.
+do_patch[postfuncs] += "update_copying_file"
+update_copying_file() {
+ # This package ships with a GPLv2 COPYING file, but the author says
+ # it is actual MIT-style license, add the correct license here to
+ # avoid confusion.
cp -f ${WORKDIR}/MIT-style-license ${S}/COPYING
}